Jump to content
  • Sign Up

Unbound Magic/Aurora Salvage Items Not Salvaging


Recommended Posts

I've been doing the collections for Aurora and all the items you get say 'can be salvaged for unbound magic' but when you go to salvage them they show as eligible then when you confirm this nothing happens. I've tried with multiple salvage kits in-case it didn't like certain ones. This is also the same for the two salvageable pre-items to wayfarers henge (Blooming/Living Druid Stone). Not sure if this is a new bug or an old one as I just started the collection a few days ago.

 

Example Item for the other part; 'Bloodstone Chip' but I have the same issue with any of the ones from the Map Master collections towards Aurora.

 

EDIT: It is worth noting I've tried making slots in other backpacks since some of mine are for specific items and things in-case this was a problem, but other items salvage there fine. Making slots in other backpack also has no effect it just comes up asking me to confirm then when I do so nothing happens.

Edited by spikecon.7809
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...