Jump to content
  • Sign Up

bug with https://api.guildwars2.com/v2/achievements/daily returning old schema even with ?v=latest


Recommended Posts

I noticed today while getting my dailies through the API was throwing an error. When I debugged my code, it looks like the endpoint today is returning the old schema for required_access:

 

https://api.guildwars2.com/v2/achievements/daily?v=latest

 

"required_access": [
        "GuildWars2",
        "HeartOfThorns",
        "PathOfFire"
      ]

 

according to the API documentation here https://wiki.guildwars2.com/wiki/API:2/achievements/daily

 

Quote
  • required_access (array) - Contains which Guild Wars 2 campaigns are required in order to see this daily achievement. Possible values: GuildWars2, and/or HeartOfThorns, and/or PathOfFire. Available on schema previous to 2019-05-16T00:00:00.000Z.
  • required_access (object - optional) - Describes if a daily requires a Guild Wars 2 campaign or not. Available on schema 2019-05-16T00:00:00.000Z or later.
    • product (string) - A Guild Wars 2 campaign. Can either be HeartOfThorns or PathOfFire.
    • condition (string) - The condition if a account can or cannot see this daily achievement. Can either be HasAccess or NoAccess.

 

Even worse, tomorrow's dailies has been switching between returning the old schema, and not returning required_access at all

 

https://api.guildwars2.com/v2/achievements/daily/tomorrow?v=latest

 

doesn't matter if I pass v=latest, or a specific date past 2019-05-16, it always returns the old schema thus breaking my code that is using the new one for quite some time

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...
2 hours ago, Healix.5819 said:

It was fixed the week that was posted.

It was‽
I’m still getting the wrong dailies on GW2Timer and assumed this was the root cause since this thread was linked on their forum.

Guess I’ll have to query the API myself and see what’s up with that, then. Thanks for the info.

Link to post
Share on other sites
36 minutes ago, nicoper.3215 said:

I’m still getting the wrong dailies on GW2Timer and assumed this was the root cause since this thread was linked on their forum.

gw2timer.com? is showing the correct dailies, so if it's wrong for you, try clearing your cache, or lazy test, open a private window.

Link to post
Share on other sites
  • 2 weeks later...
On 5/19/2022 at 5:56 PM, Pooktress.2805 said:

seems to return the correct dailies only if you don't put the `?v=latest` parameter

Are you sure? I've been using "latest" the entire time. There are multiple servers, so maybe one is wrong, but I've checked both NA (34.202.125.107, 54.162.70.13) and EU (18.195.210.70, 52.28.111.132) and they're currently accurate.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...