Jump to content
  • Sign Up

A quizzical TP issue just happened.

Recommended Posts

Was crafting an Ascended chest piece for a character,  needed Bolts of Damask, and was short the several low level cloth patches.   Hit the "O" key, bought the needed items from the TP,  got them into the TP pickup bin, but was not close to a TP point.   Logged to an alt standing in front of the TP,  picked up the 3 items, closed the TP, opened inventroy meaning to store then all into the account bank.   No dice.   I could not store in multiple tries.    Guessing that it was the fault of my level 21 pickup agent,  I moved the items up to the shared inventory box, and logged back to the crafter.  


Moved the items down to her main inventory,  tried to craft the Bolts of Damask,  found the items still missing on the recipe (even though they were clearly in view).  I tried to click and move them to bank inventory, and they would not move.   My options on the items were to mail them to someone else,  sell them on the TP,  buy more on the TP, or destroy.    I can do anything but actually use them.


Why is this happening?   I have had several frustrating crafting issues recently, after year of  lots of crafting.  (3 accounts,  25 characters,  most full exotic but 5 full ascended. I craft as much as I play).   


I cannot guess what's going on.   Can you?  How can I own then enough to sell them but not enough to just use them?? 

  • Sad 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...