Jump to content
  • Sign Up

Fort Aspenwood Meta Event Chain Bug

Recommended Posts

Howdy GW2 bug team!


Just wanted to provide a bug report for the Fort Aspenwood meta event chain, which had a strange bug this morning when a group of us tried to run the event. We were really up against the wire on the final part of phase 1, where you move through the fort destroying generators on the left and right sides. The timer was ticking down and we took out the right interior generator, and were close to removing the left-hand side one when the timer hit zero. Regardless of the imminent failure, we got an event success medal, and then the next part of the chain began, only to stall out immediately.


Not stripping the left hand generator meant none of the mech arms on the left-hand side had their shields removed.  This caused both NPCs to immediately agro the mech arm closest to the door and enter into a feedback loop of not doing any damage/being damaged. We waited around trying things until the timer went down and ended the event window.


So either assuming what happened here was the chain bugged and gave us a success when we should have failed--OR--the success was meant to occur but it didn't strip the shields off the remaining mechs.


Anyway just wanted to make a report so it was on the books, and let anyone else looking for this issue know that they're not crazy!


Thank you! 🙂

  • Like 1
  • Sad 1
Link to comment
Share on other sites

For us last night was the NPC  simply froze and the event stopped.  A few in the group said the same thing happened the previous day.  Because it happens only at night its difficult to get enough ppl and be online at the right time.  For me its pretty much only once a day.   I hate it when achievements not related to the event his inside another event. 

  • Like 2
Link to comment
Share on other sites

  • 2 months later...
  • 5 weeks later...
  • 2 weeks later...
  • 10 months later...

I was on a map about 2 weeks ago and we failed the meta because of this same bug.  Someone was on a different map, so we tried switching to that map and it had the same issue.  Quite annoying especially since the Special Ops Armor achievement was driving people to do this event.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 3 months later...
  • 2 weeks later...
  • 1 month later...
  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...