Jump to content
  • Sign Up

Recommended Posts

Posted (edited)

I recently tried booting up the game, but the screen is completely dark. There's music playing and the cursor is still visible and working but none of the graphics have loaded.  I thought it was an issue with the vpn so I disabled that, but still nothing. I don't know what is suddenly causing this. I just submitted a ticket and hoping they can find out the cause of this.

 

Has this happened to anyone else?

 

EDIT: I'm not sure what happened but it's suddenly up and running again

Edited by Mediahead.3542
Link to post
Share on other sites
  • Mediahead.3542 changed the title to Screen gone dark (Solved)
7 minutes ago, Mediahead.3542 said:

I recently tried booting up the game, but the screen is completely dark. There's music playing and the cursor is still visible and working but none of the graphics have loaded.  I thought it was an issue with the vpn so I disabled that, but still nothing. I don't know what is suddenly causing this. I just submitted a ticket and hoping they can find out the cause of this.

 

Has this happened to anyone else?

 

EDIT: I'm not sure what happened but it's suddenly up and running again

Make sure to close your Support Ticket by updating it with the phrase, "I no longer need help."

Link to post
Share on other sites
10 minutes ago, Mediahead.3542 said:

Has this happened to anyone else?

It may or may not be apply to you, but if you are using an AMD GPU and upgraded to the latest drivers you might get some weird graphical and crashes issues, since these seem to be really, really bad for GW2. I actually had to downgrade to the beta drivers since they worked fine for.

  • Haha 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...