Jump to content
  • Sign Up

"There was an unspecified Error" at account sign up.


Recommended Posts

I've convinced my housemate to give GW2 a go yet we seem totally stuck on account creation. I've had this same issue myself in the past, yet don't remember how I got around it.

After filling in all the signup boxes and clicking create account it just returns "There was an unspecified error" and advises to try again.

In total we have tried 17 different attempts on two different devices, using three different browsers, two different wifi connections as well as attempting over 4G and it returns this same error. (These steps were reccommended by people on previous posts as steps to take).

I know this isnt a new issue but besides messages from a year or so ago stating devs are "Working on it" or "Aware", there seems to be nothing recent and a fix has clearly not been attempted or has been unsuccessful, consider this a prod to bring it to attention, as I know I personally had this issue over a year ago too so this isnt recent.


If anyone previously has found a way around this though, your input would be appreciated.
TY!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...