Jump to content
  • Sign Up

New (I think) Bug that prevented me from killing Trahearne at the end of Heart of Thorns

Recommended Posts

As the title says, I had encountered a bug during my playthrough of Hearts and Minds where at the very end I was unable to kill Trahearne and finish the story. What I think went wrong is that just before or during the cinematic that takes me back to my body, I had lost client connection and got booted out to character screen. Thinking I would have to fight Mordremoth again, I logged back in only to discover that I apparently reached a checkpoint just around when the cinematic starts and am right back to when I lost connection!


Only, however, I (since I am a sylvari player) still had the condition "Mordremoth's Influence" which I presume is from the boss battle. And that bugged out the instance, as with it on and after moving to give Trahearne Caladbolg, our dialogue skipped completely and I was left unable to interact with him, which I needed to be able to kill Trahearne. The condition persisted after several quits and rejoining of instances, so I was effectively softlocked at the very end by Mordremoth.


Luckily, two kind veteran players helped me troubleshoot the bug until we developed a fix that at least, worked for me! At the end with the gang and Trahearne plus the two vets, I logged out to the character screen and logged back in. Doing so kicked all three of us out, but getting back into the story instance leads to me not having Mordremoth's Influence anymore! From then, the story progressed as normally and I finished Heart of Thorns by killing Trahearne.


I don't know for sure if this is right, but I think if you have a sylvari character, fight and beat the whole boss sequence, and lose client connection during the cinematic that takes you back to your body after the fight, you can get the Mordremoth's Influence bug. I could be completely wrong but it's at least something for the devs to search through, if they want to.


So, if you or your sylvari friends get Mordremoth's bug and are unable to finish things, this way worked to free me from his torment!


Also, for a fun little tidbit, getting Mordremoth's Influence sets you neutral or hostile to other players, letting them attack you, and (at least in the end room) you can't die, ever! 😁

Link to comment
Share on other sites

  • 2 months later...


edit: a fix that helped me, if you went through these exact events. 

you are a Sylvari.

you got to the end of the fight and the client dced, and when you came back and entered the instance, and get to trahearne and you're stuck in mordremoth's influence, restarting the mission from the start doesn't work, relogging doesn't work.

***I verified integrity of game files using steam (recovered 3 files) and then repaired the client. 

go into the folder where the gw2.exe is located, right click the .exe and create a shortcut, rename the shortcut and add 'repair' on the end (to avoid confusion) right click it again > properties and locate the target line and add '-repair' at the end of it (could be in shortcut tab of the properties window if you're using windows 10) should look something like  "C:\Games\Guild Wars 2\gw2.exe" -repair . shoul Hit ok or apply then ok, start the game up using that shortcut (another little bitty, when i first used the shortcut it stopped responding and i had to end task and load it again and then it asked if i wanted to uninstall gw2, i closed that out and tried it a third time and it started to repair itself. I went back in restarted the mission from the start by starting a past mission and then starting "hearts and minds" again and it worked (because it didn't disconnect me)

Edited by Relikane.4726
found solution.
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

I just got this bug. Have tried the fixes listed. Didnt work. The story mission disconnect bug has been going on for years, it would be nice for a fix to be found. This is still the only online game that gives me this much trouble. Disconnects only happen when in story missions, almost exclusively during cutscenes. All the fixes people always mention sometimes work but sometimes don't.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...