Jump to content
  • Sign Up

[Achievement progress blocked] Aurene's Facet of Plant

Recommended Posts

I defeated Mordremoth several times in Dragon's Stand with the Uncharged Prismatic Fragment in my inventory and Aurene's legendary weapon equipped but the last item to complete the collection never dropped.
Is there anything special to do after killing Mordremoth?

Edited by Eekoh.3987
Link to comment
Share on other sites

I have the exact same problem, wielding the Aurene's Fang and the "uncharged Fragment of Prismatic Plant" in my inventory i joined for the entire event chain and killed mordremoth twice now on 2 different days and it still didn't charge, while for the zhaitan collection it worked just fine.

Edit: as i tried the 3rd time now i realised i did not have the buff that says that i'm getting progress on the legendary and i do remember having the buff on the zaithan collection while defending arah. So no point in trying if i it isn't fixed yet and have the buff

Edited by RDEF.8513
Link to comment
Share on other sites

  • 7 months later...

same here. I simply cannot finish this achievement. Was standing on foot on one of the isles. Wielding aurene leg. i dont have another weapon equipped on weapon swap. it didnt work. and i heard you dont need 100% participation either.

EDIT: Apparently I was supposed to carry the Uncharged Fragment of Prismatic Plant in my inventory. I have the achievement completed now.

Edited by LeoXander.2798
additional info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...