Jump to content
  • Sign Up

Installer/client not working (Windows 11?)


Recommended Posts

Hello everyone!

 

Returning player here, last time I played regularly Windows 10 was barely a thing, and I expected to be able to play on Windows 11 without too many issues, but apparently the game is not supported on that OS yet.

 

In brief: the first time I downloaded the game without issues, but one it started running I could not access the BLTP. After a day or two, I opened the client to find out that it gave the error message "Connection error(s) detected. Retrying..." despite the fact that I was connected to the internet and (almost) every other software in my PC worked as intended.

 

So far, for some reason, changing my server DNS, changing the client name and saving it into a different folder is the only fix, but it requires me to download the game anew every time. Anet customer service offered a number of other workarounds, which failed (it was a 2-week long saga) before defaulting to the usual "It's Windows 11, we don't know" line. Even with this workaround, after a couple of days the client stops working again, and BLTP never works.

 

Has anyone had this kind of issue in the past?

 

Thank you

Link to comment
Share on other sites

Some of your downloaded files are broken, which is why moving it to another folder and starting over helps. Make sure you let the game fully patch before entering, because if you get a glitch or a crash while its patching a file while the game is running, it'll destroy the file and result in problems like this.

 

Also, make sure the game is in your desktop, documents or somewhere else you have write permissions to, or you'll get write errors resulting in similar problems. (Program Files isn't writable by users.)

 

Make backups of your "Gw2.dat" regularly so you don't have to redownload the game.

Edited by Mariyuuna.6508
Link to comment
Share on other sites

9 hours ago, Inculpatus cedo.9234 said:

As far as the Trading Post goes, did you clear the GW2 cache?

Are you making sure to download to someplace other than a .tmp file/folder? Making sure to download elsewhere than 'Program Files'? 

 

Yup, a subdirectory of :C/Users/MyUserName in one case, and Desktop when I did it the first time. I think I cleared the cache once on the advice of customer service, but I'm not sure. What's the "run" command for that?

 

8 hours ago, Mariyuuna.6508 said:

Some of your downloaded files are broken, which is why moving it to another folder and starting over helps. Make sure you let the game fully patch before entering, because if you get a glitch or a crash while its patching a file while the game is running, it'll destroy the file and result in problems like this.

 

Also, make sure the game is in your desktop, documents or somewhere else you have write permissions to, or you'll get write errors resulting in similar problems. (Program Files isn't writable by users.)

 

Make backups of your "Gw2.dat" regularly so you don't have to redownload the game.

 

1-3) Got it, I alredy made sure to do that last time I entered, but I still got this problem again. I did not save a backup of the Gw2 .dat file before the issue presented itself again, so will I have to download it again and, if it works, save that .dat file and use it as a backup?
Either way, sometimes I get the same error on the install client even before I start downloading the game, so how are corrupted game data responsible for that?

2) See above, I should have write privileges in my Users section
 

Thanks!!!

Edited by MarcoThePhoenix.1984
Link to comment
Share on other sites

On 8/4/2022 at 3:19 PM, MarcoThePhoenix.1984 said:

So far, for some reason, changing my server DNS, changing the client name and saving it into a different folder is the only fix, but it requires me to download the game anew every time.

Sounds like you have security software blocking it. Both Gw2-64.exe and bin64/CoherentUI_Host.exe need to be whitelisted.

Link to comment
Share on other sites

  • 2 weeks later...

I just got a new laptop with Windows 11 on it, and I cannot log in at character select, getting error codes 42 and 58.  Reinstalled the game twice, rebooted router, removed firewalls and gave permissions etc and still won't play, says it cannot connect to the server. I JUST submitted a ticket for this issue and waiting to hear back but I saw your post and see that you think it's Windows 11 OS creating the issue, have you resolved the issue yet? Curious if or how your issue was resolved since it sounds similar to mine and I may have to just play this game on my old laptop with Windows 10, which sucks, because I got the new laptop to play this game with better performance and graphics. Ironic.  

Edited by TJWarszawa.9643
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...