Jump to content
  • Sign Up

Freezing on Loading Screen


Recommended Posts

My problem started Thursday.  I can log in and get to the character screen.  I can even sometimes start character, but when I switch characters or try to go into another zone, the game will freeze on the loading screen.  I have tried different ideas I have found, but the problem will still occur.

 

I may be able to switch zones a couple of times, but eventually it will freeze and I have to open the task manager to force close the game.

 

Please Help

Link to comment
Share on other sites

This exact same issue is impacting me and two other GW2 players in my household. It started on Thursday as well.

 

We have tried the following, without success:

Reinstalled GW2
Restarted router
Port forwarding on router
Password change

 

This issue is specific to GW2. All other games and websites function properly. We contacted our ISP, they confirmed the problem is not on our end. Bumping this for attention to the issue.
 

Edited by Shannon.6920
  • Confused 1
Link to comment
Share on other sites

Exact same issue for me as well, started Thursday night. Funny enough I can play and login into most characters fine after sitting in a long loading screen. But one of my characters gets kicked back to character select everytime. I have tried all the following fixes above, and been in contact with support as well. Still happening as of now. 

Link to comment
Share on other sites

 

2 minutes ago, Ashantara.8731 said:

While it would be quite the conincident, I still have to ask: is any of you experiencing high temps for the hardware (CPU, GPU)?

Or is the freeze still allowing you to open other programs, hop on the desktop, etc?

 

I can still hop and use other programs. It's not the laptop failing, is the game crashing 

Link to comment
Share on other sites

7 minutes ago, Ashantara.8731 said:

Okay, so the game actually crashes? Because there is a difference between a freeze and a crash. :classic_huh:

Just for clarity my game doesn't crash in case there ends up being separate issues. I've narrowed the problem down using the -maploadinfo argument in that when changing maps it just never starts the process of loading. It stays at 0% indefinitely; it seems to never receive a response from the server to begin loading in the first place. Using alt+f4 and trying again is something I've had to do constantly anytime I try to switch maps. Largely this makes the game unplayable since I'm primarily a WvW player and switching maps is a very common occurrence.
My only hope is that maybe it'll get fixed before the Steam launch so I can participate in the community building events I had planned to bring in new players.

  • Like 2
Link to comment
Share on other sites

2 hours ago, Panders.5230 said:

Just for clarity my game doesn't crash in case there ends up being separate issues. I've narrowed the problem down using the -maploadinfo argument in that when changing maps it just never starts the process of loading. It stays at 0% indefinitely; it seems to never receive a response from the server to begin loading in the first place. Using alt+f4 and trying again is something I've had to do constantly anytime I try to switch maps. Largely this makes the game unplayable since I'm primarily a WvW player and switching maps is a very common occurrence.
My only hope is that maybe it'll get fixed before the Steam launch so I can participate in the community building events I had planned to bring in new players.

 

This is my issue as well. I cannot play multiple characters (which requires loading in separately each time) or map change without completely shutting down the client and restarting. Even if I can get into a map, I will almost certainly disconnect within minutes. The game is basically unplayable for me and the other two people I live with in my home that have GW2 accounts and their own computers.

Link to comment
Share on other sites

Its not a network issue, its a server-side issue that started near End of Dragons release. They've patched it several times since then, but it keeps returning somehow. For unknown reasons, the server itself stalls out while serving resources to the client during a map load, especially during character change.

 

In the past you could see this by turning on maploadinfo, I'm not sure if it still works, though.

Edited by Mariyuuna.6508
Link to comment
Share on other sites

8 hours ago, Knightden.9450 said:

Maybe a matter of translation for me, not my native language. But at least unexpected disconnection

Okay, we are talking about three separate issues here:

  • The game freezes on map change (which is this thread's topic)
  • The game crashes on several occasions (an issue that many experience, especially under DX11)
  • The game disconnects you (another issue that many experience; I, for instance, while idling at the beginning of Strike Missions and Raids or during Story cutscenes)
Edited by Ashantara.8731
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...