Jump to content
  • Sign Up

Logitech G Hub vs GW 2

Recommended Posts

For starters, sorry if it's a bad place, but I haven't found a better one. After the recent Logitech G Hub upgrade, the program does not see the GW 2 mouse profile and even claims that the game itself is not installed (non Steam). Apparently, it only detects the game on Steam.

I solved it halfway. I added a new profile leading to the GW exe file and reassigned the keys. Unfortunately, the elite skill still doesn't work. I'm trying to report a bug with Logitech, but I don't see an option ...

As naive as it sounds, could Developers consult this bug with Logitech? Playing GW without assigned keys is almost like playing without an arm ....



Link to comment
Share on other sites

I have a temporary workaround for this.

Open G Hub, switch to the Guild Wars 2 profile with your settings, and next to the "Assignments" heading, click the little lock so that it's in its locked state. That will temporarily set G Hub to always use those settings, regardless of which window is open. This does mean that your GW2 binds will be in place for everything until you unlock it, so it might be annoying if you use the mouse buttons for browser or other stuff in the background. Remember to unlock it when you need it to work with other apps.

Edited by Thalfon.1269
Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...