Jump to content
  • Sign Up

Launcher wont launch!!

Recommended Posts

Hi. Can anyone help me? The Launcher won't luanch. When i open it and nothing shows up, not even a crash message on the 64 bit Exe, but in the Task Manager I see the game "running". I've tried restarting my pc multiple times already


i've tried running the game on admin, and I dont think the problem is with the antivirus since mine is always off. 


Ive been having this problem since last month. hope that anyone can help me. Thanks

Link to comment
Share on other sites

10 hours ago, Inculpatus cedo.9234 said:

Using anything with overlays, like Discord, etc.?  Try disabling/removing them. 

No. They are not currently open.


10 hours ago, codeman.3425 said:

It does take a little while to start the game, dependent on your PC specs. 

The problem is with the launcher. It's launching but shows nothing onscreen


6 hours ago, Chaba.5410 said:

Have you tried repairing the client?

I tried that. But i need to repair the client everytime i would like to start the client

Link to comment
Share on other sites

Is it showing nothing at all, or does it show the initial gray window, then nothing? After the initial window is where they switch over to using CoherentUI and the launcher will be invisible until CoherentUI is fully loaded, which can actually fail and do nothing, or appear several minutes later. There will be a debug.log file in the bin64 folder where CoherentUI logs its errors, but from what I've seen, it's not very meaningful.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...