Jump to content
  • Sign Up

Caught between a rock and a hard place...


Recommended Posts

   Evening everyone. 🙂

   I am here in the hopes that maybe someone will be able to offer some help for a situation I am currently dealing with in game. I recently purchased gems from the Black Lion Trading Post, and it went threw with no issue, even though afterwards I had to wait to buy/sell thing in the trading post due to the "pending review" message. That of course went away too after a few hours, and can and have been using the market quite satisfactorily. However, for almost 24 hrs now I have been having another issue which is frustrating me to no end, and that is when I go to try and purchase more Gems off the market, every option to do so is "reddened" out, and when I hit the buy gems option and choose the one I want, it just gives me the orange circle of death loading cursor which never ends. 😞

   Now I got GW2 via Steam, and yes I am always logged into it when I play. In addition, I do have money in my Steam Wallet to pay for such Gems as well. Soooo, after some advice from a friend, I sent off a support ticket to Arenanet, but they keep telling me this:

----------------------------------------------------------------------

"We apologize for any inconvenience this may have caused you regarding this issue.
I understand that it can be frustrating. Unfortunately, Please keep in mind that we can only assist you if your issue is purchasing directly on Arenanet. However, Based on the issue or error you're having, you will have to reach out to Steam Support directly for assistance through this link:
https://help.steampowered.com/en/."

----------------------------------------------------------------------

   Well doing what was asked, I hit the link and tried to send out a Steam ticket, but wouldn't you know it, I am getting THIS message from them:

----------------------------------------------------------------------

"Unfortunately, Steam Support cannot provide the best assistance with games made by other companies. Please click the link below for information about how to contact the support team for this game."

----------------------------------------------------------------------

   So now I am incredibly frustrated, and even a tiny bit angry about all of this, and about two companies that are not only saying "talk to the other company", but not doing anything to help me with this issue. I am no game coder or designer, and understand such issues can be problematic, but come on... this is totally unacceptable coming from two gaming companies. By all appearances, this is a in game issue (which is under the Arenanet umbrella as such), and so as such I would have assumed that this wouldn't be as troublesome as having my teeth pulled. And here I am, caught in the middle of a void because each company is saying its not their issue.

   That is wholly unacceptable. And yeah, if all of this sounds a bit harsh, please just chalk it up to me being very frustrated atm, especially seeing as I had no real issue buying (and getting) gems before. So please, please if anyone has any suggestions or help they can give me, I would greatly appreciate it. And also Arenanet, please, please give a old man with a bad heart and medical issues a break here. All I want is some simple resolution to this issue, for this great game I am having a great time with, and not anything like I have been getting atm. So please help, because right now I am sorta at my wits end and have no idea what to do next... 😞 😞

Peace (though not feeling it much atm)... 

Link to comment
Share on other sites

Well, even before Steam accounts released, Gem issues were stated to be taken care of by Steam (Valve).  So, it's definitely in Steam (Valve) bailiwick.

You could try purchasing Gems on the buy.guildwars2.com site; no idea if that would work.  If it doesn't, though, that would be ArenaNet's realm of service.

Good luck. 

https://help.guildwars2.com/hc/en-us/articles/360053416353-Steam-FAQ

Link to comment
Share on other sites

   Ok, update time...

   Having read your replies, I did some more work and found out that my steam system did not have its overlay activated, and so turning it on I tried it again... to no avail unfortunately. So not giving up, as I rarely do, I did a deep dive into my PC to see if there was a problem there, and after also doing a bunch of research on the internet (and with the help of a friend who knows PC's, coding, and the web), I found out that the game was not reacting well with the great antivirus & firewall I have on my system.

   So after reducing it and also having my steam overlay activated, I am pleased to say that I was able to finally purchase the gems I wanted. So basically, it was a combination of two things on my PC/end that was hindering me, not the company's per say (Arenanet & Steam) that was the issue (I apologize for that guys). So after getting my gems, I turned back up my system settings and am all good now. Thank you for your help guys, and God bless you both...

Peace...

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...