Jump to content
  • Sign Up

[SPOILERS] Someone in Need glitch


Recommended Posts

If you haven't started the Someone in Need collection, just use the same character to do the whole collection, and you should be fine, and you don't have to read the rest of this and get the puzzles spoiled.

If, like me, you are too clever for your own good and glitched out, I have good news, in that I was eventually able to reset myself after glitching myself into a dead end. If you want to avoid spoilers, my best advice to you is to go back to previous locations and look for a collection marker that didn't go away like it should have, then stop by all the points you were able to do from that one forward until you start getting them again.

From here, there's gonna be spoilers, so you've been warned.

Everything was fine through the point where I had to go to the Hidden Garden. Since I have a character parked there for the, well, hidden garden, I just switched over, not realizing there was a new portal related to the collection. When I got there, someone with a mentor tag was standing on a spot where a bunch of characters were running up, stopping to interact, and then darting away, so I assumed I didn't see the collection marker because of the tag.

I was able to interact at that point, and then I could go around the jp and complete the collection task. Back to LA, on to the next one, where I had no trouble in Morgan's Spiral/Dark Reverie, seeing all the collection markers and interacting with them without trouble. Back to LA, and off to Zinn's Cave. This was my first indication that something was wrong. April didn't show up, either outside to taunt me or inside to interact with.  I tried going back out and back in, changing maps, giving L.O.X. the wrong answer (which got me knocked inside the rocks, and even logging out to character and back didn't solve that--I had to wp and start over). Changed maps again, finally just guessed where April was and what emotes to use, and the book popped up. Back to LA.

Off to Desert Highlands. No interactable. No ability to interact with the invisible orb in the Cold Room. Checked the Cobwebbed room. Nothing to interact with. Lot of dying. So much dying. Tried switching characters, no joy.

Eventually, I worked out that I'd missed the entry step at the Hidden Garden. Went back to Mount Maelstrom, and the collection icon was outside the garden, but it disappeared as I approached. Switched over to my parked character, and the collection marker was outside until I moved, then it was gone. Gave up, and moved my main back to Arborstone.

Decided not to give up, and took my main back to Mount Maelstrom and jumped around and clicked all over the area where the collection entry portal should have been, no invisible portal. Okay, fine. Go back to LA and talk to Zinnia. Go back to Caledon and do Morgan's Spiral, no interactable at the end. Go back to LA and talk to Zinnia. Go back to Zinn's Cave.

April appears outside! Aprils appear inside! Recomplete the step. Back to LA. Can't remember if this is new dialogue and I'd gone off the provided clues or if I'd gotten it before, but off to Desert Highlands I go.

April appears to taunt me again! I am finally able to complete the collection without mishap.

I expect this will be less likely to turn up as more people finish it and it's less likely there will be a tag on top of the Hidden Garden interactable, but I do know there are several characters parked in there, so if anyone else clevers themselves into a corner, hopefully this will help them out of it until it gets patched.

Harbinger of Chaos, indeed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...