Jump to content
  • Sign Up

Update gone wrong


Recommended Posts

Hello everyone.

 

Has anyone else ever been having trouble with this afternoon's update? I only downloaded a few KBs or maybe MBs of files before getting a windows permissions error.

Now the executable has 0 KB size and is no longer usable.

Obviously this means that the repair  is not usable too ... 😞 

 

Link to comment
Share on other sites

The first thing the game does is patch the client executable. The old file will be named Gw2.tmp, just move it back to Gw2-64.exe and the game should start again, but this sounds like your antivirus tried to stop the update.

 

Also make sure you have a good write permissions to the folder, it should never be in Program Files.

 

Whatever you do, don't delete Gw2.dat, as its a 60GB datafile and you'll have to redownload the whole game if you delete it. Worst case scenario just get a new .exe file from the website.

 

Gw2-Setup.exe is the same file too btw, just rename it and it'll run normally.

Edited by Mariyuuna.6508
Link to comment
Share on other sites

Hey Mariyuuna.6508, thanks for the tip.

Unfortunately don't have an antivirus, and the game location is in a secondary ssd disk. 

Trying to manually revert the update was the first thing I tried but the exec is somehow corrupted.

🥲

 

(tried https://help.guildwars2.com/hc/en-us/articles/201863008-Repairing-the-Game-Client > but no results..)

Quote

 

If repairing your client doesn’t solve your problem, you can also try cleaning up the temporary files in your game cache. You can do this using following these steps:

  1. Open your windows explorer browser.
  2. In the navigation bar, type %temp% to open your temporary folder.
  3. Search for any folders that begin with “gw2cache-“ followed by a string of numbers.
  4. Delete these folders.
  5. Open Guild Wars 2.

While you will need to re-download any files that are necessary to run the game, this process will help replace any corrupted files that might be lingering in your game cache.

 

 

Luckily I have a fast connection, so I just downloaded the game again and prob is now solved.🤗

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...