Jump to content
  • Sign Up

Thanks for the Steam version Anet!

Recommended Posts

Just a heads up if you're having issues with X11 and GW2 but don't want to use Wayland.


You can disable desktop compositing with a widget (KDE):



Or with a keyboard shortcut:

Alt+Shift+F12 (on Manjaro - look for your distro's shortcut)


Even with the shortcut, i still perfer having the widget cause it indicates if the compositor is on or off.


There's some transparency issues with the launcher, but the game works like it does on Wayland!

No issues found for now!


I guess i could write a script as well, and disable compositing, run game, then re-enable compositing upon exit, but i'm good for now. Anyway, X should now work just as well!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...