Jump to content
  • Sign Up

Gem Store not loading for single account

Recommended Posts

Hi Everyone, 


I'm hoping someone has an idea to help. The gem store won't load for my account. it just remains blank with unclickable category tabs. gem exchange and trading post work fine. there are several other accounts that log in from this computer that can access the gem store fine. Support is trying to blame it on my ISP saying that is causing issues, except I don't experience the issues they describe and (as I mentioned) several other accounts can log in and access the Gem Store without issue.


I also tried clearing the GW2 cache and flushing the DNS like what is recommended for the trading post not loading. it didn't make a difference.


any ideas?

Link to comment
Share on other sites

Is this a Steam account?

Do you have some sort of firewall/VPN/proxy differences between your Windows account and the other users on that computer?  Under %AppData%/Roaming/Guild Wars 2 do you have a bunch of Coherent Dumps or something?  Maybe your %AppData%/Roaming/Guild Wars 2/Local.dat needs repair/removal?

Edited by Chaba.5410
Link to comment
Share on other sites

  • 1 month later...

I am bumping this topic because since the SAB patch, I have been having similar issues as with Iyatil.7580. I am not able to access the Gem store. The window stays blank with no way to select any of the catagories. However, the Currency Exchange and Trading Post function just like normal.

I hope this is a quick fix because being unable to use my gems that I paid for is a bit upsetting.

  • Sad 1
Link to comment
Share on other sites

Disregard my last post. I have since discovered that once I cleared my cache, the gemstore worked normally.

For those that may not know how, here's how to do it. This is taken from the Trobleshooting Trading Post support thread

  1. Completely close the game.
  2. Hold down the Windows and key to open the Run prompt.
  3. Type %temp% in the box that appears and click OK.
  4. Find any folders named "gw2cache-(code)" and delete them.
    • Example: gw2cache-(50641E0B-3AD4-1601-081E-6450D43A0116)

  5. Re-launch the game.


Edited by Artasid.7612
  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...