Jump to content
  • Sign Up

Latency - Due to Older Pc - preventing Skyscale Reflexes completion

Recommended Posts

Hello Everyone!


I know this is a topic once brought up however that was years ago and I'm on a great computer but i'm bias and it's 9 years old as well as I have no options but one for a internet connection.  That's fine for the kind of playing I generally do annoying but okay.  However there are a few things that present a huge issue such as this..


I've spent a great deal of time, effort, and gold for getting my skyscale, excited I got to the hide and seek did that and now onto playing catch.  I'm simply not able to get it I can't even get it on easy for crying out loud.  I got 9 one time every other time 4 is the limit.  I'm in the circle everytime!  but it fails.  I see me in the circle, but the game doesn't.


I've tried all the info i could find online - staying in the center - every speed benifit you can get your hands on etc - lowering graphics -  Nothing is allowing me to move on.  It's a shame if i can't get my skyscale after all that I've been through to this point to have one silly little game ( cute as it may be) preventing my progress.


If anyone can help that would be wonderful.

  • Sad 1
Link to comment
Share on other sites

Tried a thief with shortbow 5?


Now when I think about it abit more, have you tried advertising in the lfg for other people that need it too.

You have them start the instance do the thing and you accept progress?

Edited by Linken.6345
Link to comment
Share on other sites

You don't stand in the circle, the circle is just where the ball lands. You need to be inbetween the ball and the circle at about the right height while facing it, similar to how other catch minigames work.


I struggled pretty badly even on a 100ms connection until I realised this.

Edited by SoftFootpaws.9134
  • Like 1
  • Confused 2
Link to comment
Share on other sites

Mirage mesmer have a short cd, 3 ammo, teleport for ult. If you havent tried yet. 

I kinda doubt its hardware, more likely its the internet connection. Have you tried mobile network (wifi hotspot your mobile phone). 

Edited by Cuks.8241
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...