Jump to content
  • Sign Up

Capacitive Bottle wont go in collection


Recommended Posts

Hi, I have looked everywhere try to find a solution and I am at my wits end? So I am working on my first legendary, Bolt. I crafted the capacitive bottle and tonight I finished the energy bottle collection, however my Capacitive bottle will not go into the collection. I read about the glitch and the fix where you right click the bottle and "add to collection" but when I right click I don't get that option.

 I've gone and deleted the bottle, and bought another one but still the same problem.

 I have also tried to "send a ticket" on support, but everytime I click "send a ticket" it tells me to log in but when I click "Log In" it just refreshes the page I am on. So I am hoping someone from Arenanet see's this and can help me.

 I've been working for awhile on my first Legendary and I feel so close I can taste it, but tonight I complete the bottle collection and for this to happen. 😪

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...