Jump to content
  • Sign Up

Unable to initialize 3D output


Recommended Posts

Same issue here im running dx11. I just updated my drivers, removed arcdps, cleared my local.dat file, uninstalled gw2 then reinstalled and gw2 still not working.

 

More info in case its relevant/helps:

Gw2 had been getting increasingly unstable (about 2 or 3 crashes a day) the past few weeks with trading post not loading/crashing game, login server popup occuring more frequently. Still consistently playable otherwise especially wvw and raids.

 

For the first time ever (almost 6 years) the downloader kept stopping during reinstall, and i had to keep exiting and relaunching it even after adding -patchconnections 20 to the target field. 

 

Havent updated windows tho will try that next.

 

I had to manually update my drivers, my computer considers my gpu to be a 200 series and AMD considers it to be a 300 series so prior to patch i had thought my gpu was updated fully.

 

Amd radeon r9 380, amd fx8320e 8 core processor, win 10 pro 64 bit, build 10240

Edited by rhaz.2394
  • Sad 1
Link to comment
Share on other sites

Oh also this issue had popped up before this recent patch when i tried dx11, and gw2 wouldnt launch so i would revert back to dx9 in the past. I did check my specs and its dx11 compatible and is running dx11. But now reverting back is not an option

Edited by rhaz.2394
  • Sad 1
Link to comment
Share on other sites

52 minutes ago, rhaz.2394 said:

Oh also this issue had popped up before this recent patch when i tried dx11, and gw2 wouldnt launch so i would revert back to dx9 in the past. I did check my specs and its dx11 compatible and is running dx11. But now reverting back is not an option

Double check your graphics card support of DX11 because it turns out some older cards say DX11, but only support up to "feature level 10".

Someone posted this earlier in another thread:  https://solidlystated.com/hardware/list-of-directx-12-and-directx-11-compatible-video-cards/

Link to comment
Share on other sites

6 hours ago, rhaz.2394 said:

Oh also this issue had popped up before this recent patch when i tried dx11, and gw2 wouldnt launch so i would revert back to dx9 in the past. I did check my specs and its dx11 compatible and is running dx11. But now reverting back is not an option

From the Wiki:  https://wiki.guildwars2.com/wiki/Command_line_arguments#-dx9

  • Confused 1
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...