Jump to content
  • Sign Up

*FIX for me* Stuttering while moving camera / Micro Stuttering in General


Recommended Posts

Hello GW2 Community, 
after reading "dozens" of stuttering threads after the DX11 Patch, even with high end components. Trying dozens of fixes like setting the Mouse Polling Rate on Low, VSYNC On etc. 
I was finally getting some results and maybe some real fix for "ME".  

Let me start from the beginning and with my PC Specs: 

Intel I5-13600KF 
32GB DRR4 Ram 3000MHZ
1TB WD_Black SN770 Storage
AMD Radeon RX 6950 XT

First... and its weird: Its definitely a GW2 DX11 Problem. My GF has older components and had no problems at all. No Micro Stuttering, no nothing. 
But she had Windows 10 instead of Windows 11. But i thought, that could not be the problem. Man, i was wrong. 

After i reinstalled my whole Windows 11 to Windows 10 with no BackUp of my Data, just because of GW2 *Im a bit dumb*, installed my graphics driver only without the Adrenaline Part and downloaded GW2, i'm having less fps stuttering while moving the camera. But thats not it, after i activated VSync i've got rid of all the Stuttering and have smooth gameplay now. 

So what was the problem then? - Guess for me it was W11 paired with DX11 and the Vsync Option what was not working at all ingame. I mean, you can see the FPS in the GW2 Options. After i checked the VSync Option in GW2 with W11, there was still no Cap. Now with W10 it does what it should do. 

I hope, somebody got the same results as me, and got it fixed for now. 

@ArenaNet , please look into this!

Best regards

 

//Edit
Short things short for Fix: 

Graphics Driver Only (Not tested if its a must be)
Windows 10 instead of Windows 11
GW2 checked Box VSync (GW2 has problems with High FPS Rate like 250, drops to 170 and starts having stuttering. Even with FreeSync Premium activated, so better to cap it) 

 

From KrHome.1920 - AMD Graphic Users

Quote

GW2 does stutter for ages now. The game has poor frame pacing. The fix is to prerender frames to even out the frametimes (tradeoff: this increases input lag). Since you have an AMD card, you are lucky as you have two ways to fix this:

1. Force VSync in the driver menu (Graphics Tab => Wait for Vertical Refresh => Always On)

2. Enable FRTC (NOT Radeon Chill!) (Graphics Tab => Advanced => Frame Rate Target Control => Enabled => select your desired framerate)

Pick 1. if your monitor refresh rate is also the framerate you want to target. Pick 2. if you want to target a framerate below your monitor refresh rate.

 

Edited by NoSensey.9280
Link to comment
Share on other sites

GW2 does stutter for ages now. The game has poor frame pacing. The fix is to prerender frames to even out the frametimes (tradeoff: this increases input lag). Since you have an AMD card, you are lucky as you have two ways to fix this:

1. Force VSync in the driver menu (Graphics Tab => Wait for Vertical Refresh => Always On)

2. Enable FRTC (NOT Radeon Chill!) (Graphics Tab => Advanced => Frame Rate Target Control => Enabled => select your desired framerate)

Pick 1. if your monitor refresh rate is also the framerate you want to target. Pick 2. if you want to target a framerate below your monitor refresh rate.

Edited by KrHome.1920
  • Like 1
  • Sad 2
Link to comment
Share on other sites

Your issue has nothing to do with Win11. I am using Win11 too. GW2 only has acceptable frametimes when you cap you framerate with a limiter that does not bypass the render ahead queue (CHill does and RTSS does too, that's why both have a low input lag and Vsync and FRTC doesn't).

You have to buffer frames in the render ahead queue for this game to pace its frames properly. There is no other fix.

  • Confused 1
  • Sad 1
Link to comment
Share on other sites

Just now, KrHome.1920 said:

Your issue has nothing to do with Win11. I am using Win11 too. GW2 only has acceptable frametimes when you cap you framerate with a limiter that does not bypass the render ahead queue (CHill does and RTSS does too, that's why both have a low input lag and Vsync and FRTC doesn't).

You have to buffer frames in the render ahead queue for this game to pace its frames properly. There is no other fix.

Could be. Could be not. I couldnt even activate VSync or FRTC. It had no effect on GW2. Reinstalled GW2. Still. It had no effect. 
Reinstalled Drivers. No Effect. Did Windows 11 Updates. No Effect. Downgraded to Windows 10. Now it works. 

I understand what youre saying. And im with you. But that was my personal fix for the whole 2 day frustration.

  • Like 1
  • Sad 1
Link to comment
Share on other sites

According to your opening post you fixed it via enabling VSync ingame.

This would (or at least should) have worked in Win11 too.

For most games it doesn't matter whether you enable VSync in the driver or ingame. I prefer the driver as it is more reliable. Why it didn't work for you I don't know. Maybe a corrupted driver installation.

  • Confused 1
  • Sad 1
Link to comment
Share on other sites

  • 10 months later...

Another potential fix on amd 6xxx cards after upgrading from Win10 to Win11

- disable "AMD Fluid Motion Frames" - that fixed the mouse lag by ~90% but still a tiny little lag on slow mouse moves
- windows -> settings -> system -> display -> graphics -> custom options for apps -> guild wars 2 games client -> change from "let windows decide" to "high performance...GPU: AMD.." - that fixed the missing 10% accuracy.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...