Jump to content
  • Sign Up

Low FPS / Lag Issues [MERGED]


Recommended Posts

  • Replies 408
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

You  might consider submitting an in-game Bug Report, as there is no guarantee this particular post will be noticed.   Good luck. 

@Bioshockwave.5074 said:Alsp, can someone explain why my game client is connecting to EU server where in fact i play in NA (blackgate)?

If you originally used a EU key to register your account or live closer to the EU servers, you'll still connect to some of the EU services regardless of which server you've chosen to play on or where you live. Where you're actually playing however, and what your latency is, is determined by the map instance and is based solely on the region you've selected.

Link to post
Share on other sites

If you originally used a EU key to register your account or live closer to the EU servers, you'll still connect to some of the EU services regardless of which server you've chosen to play on or where you live. Where you're actually playing however, and what your latency is, is determined by the map instance and is based solely on the region you've selected.

I live in Philippines and i don't think i am closer to where the EU servers are located. This is the first time i am getting high latency after they moved the servers from Central US to Eastern US (i believe it's amazon server). I also used NA keys to register my account, bought it from the gw2 website itself. Been playing since beta days..

Link to post
Share on other sites

I've been suffering heavy ping spikes over the past couple of weeks, which I've never had before - I'm fairly sure it's just in the evenings (roughly 20:00 onward - UK), but not 100% sure.

Each time I've used the GW2 diagnostic, it looks like the issue's notable on the 3 hops prior to the last hop (ncsoft)(^ vague description, because I'm trying to make sense out of something I don't fully understand :D)

But yeah, as written countless times above, the lag's pretty much unplayable.

Link to post
Share on other sites

@Hushy.9530 said:sumbit tickets guys or they wont fix it!

I don't even know if the guys that get the ticket actually know what is going on.Who knows, maybe they read a few CCNA books, did exam and became network engineers.Cos every time i send them the pingplotter report with Game Advisor report, i get told issue is with my ISP.No other explanation like, oh you are dropping packets at this hop or we see problem at this router. No...just oh its your ISP.These are ISPs i've had so far.TPG then MyRepublic Gamer account then Mungi and in 3 days time will swap to another.So basically all Anet is saying that all 3 of those ISPs don't now what they are doing.Like seriously, i enter WvW or Teq event with 250-280ms.If a large group comes in WvW, it lags.If in Teq before fight is fine, as soon as fight starts...600 to 4000ms+. This just results in disconnection.Why not just give us guys from OCX or SEA a server? People been asking for so long.

Link to post
Share on other sites

Having the same problem on Lenovo Legion Y720, just chilling in Queensdale with friends and suddenly fps drop to slide-show.Trying to install older driver, hope it can help. But i guess its game problem, not driver at all.

Upd - it doesnt work, still have random fps drops without any reason.

Link to post
Share on other sites

Ever since I bought PoF I knew they are only focusing on the amercian region but I still bought it thinking that they shouldn't be that heartless. Nope, the support for anything outside of america is non existent. Tech support will keep telling you to flash DNS etc, but they know it's their server location problem so they will keep stalling by doing technical support for your computer. I've given up on arenaNet now. This is the last time I will ever get scammed by them.

Link to post
Share on other sites

any solutions so far from Arena Net? or they will remain idle? its shame to have a system that can play all new games with more than 100fps , and in an mmo the fps drop to 20.... are they willing to fix they issue ? cause its clearly the game's fault.

Link to post
Share on other sites

I'm getting massive lag spikes too, in fact, all of us in our static fractal group / guild have the same issue. We're from Argentina, ping goes from 170 to 4k, it's absolutely impossible to play (really frustrating as druid). Its been a week or so. PLEASE, do something.

Link to post
Share on other sites

@virus.2307 said:any solutions so far from Arena Net? or they will remain idle? its shame to have a system that can play all new games with more than 100fps , and in an mmo the fps drop to 20.... are they willing to fix they issue ? cause its clearly the game's fault.

It's unlikely ArenaNet will do anything about.. well, anything if they can get away with it. five year+ hacker issue that's blatant and ArenaNet knows about it, nothing being done about that. Sloppy optimization, nothing being done about that. PCs that should be running GW2 at 100~200fps are barely running the game at 30fps. ArenaNet needs a big wake up call, because GW2 is a dead game.

I logged in, checked my fps and realized even after the GPU upgrade the fps is way worse than what it was before. How in the FUCK does ArenaNet manage to worsen FPS from a 750 ti to a 1080? Seriously, Anet has to have all levels of rtard to manage something that atrocious.

Link to post
Share on other sites

day 3 and still cant play

fix your shit anet

inb4 its my net:

Pinging google.ca [2404:6800:4006:802::2003] with 32 bytes of data:Reply from 2404:6800:4006:802::2003: time=131msReply from 2404:6800:4006:802::2003: time=125msReply from 2404:6800:4006:802::2003: time=134msReply from 2404:6800:4006:802::2003: time=87msReply from 2404:6800:4006:802::2003: time=116msReply from 2404:6800:4006:802::2003: time=101msReply from 2404:6800:4006:802::2003: time=118msReply from 2404:6800:4006:802::2003: time=121msReply from 2404:6800:4006:802::2003: time=131msReply from 2404:6800:4006:802::2003: time=112msReply from 2404:6800:4006:802::2003: time=143msReply from 2404:6800:4006:802::2003: time=118msReply from 2404:6800:4006:802::2003: time=132msReply from 2404:6800:4006:802::2003: time=129msReply from 2404:6800:4006:802::2003: time=134msReply from 2404:6800:4006:802::2003: time=124msReply from 2404:6800:4006:802::2003: time=115msReply from 2404:6800:4006:802::2003: time=84ms

Ping statistics for 2404:6800:4006:802::2003:Packets: Sent = 18, Received = 18, Lost = 0 (0% loss),Approximate round trip times in milli-seconds:Minimum = 84ms, Maximum = 143ms, Average = 119ms

ran that the same time I was downloading at 350mbps from steam so yeah, its not my internet

Link to post
Share on other sites

@Levijeh.1467 said:Getting random lag spikes from south america as well, I usually had around 115ms, but now random spikes from 240ms to 1200ms, it's unplayable some times. It's not my ISP, it's gw2 servers.

They know about it, but there's nothing we can do. You need to think in their point of view, once you bought it the money is already in their pocket. From that point on, they can ignore you. Almost half of the forums is filled with people talking about bad connections since amazon servers. But amazon servers are so bloody cheap, which reduces maintenance cost. So more revenue.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...