Jump to content
  • Sign Up

I broke something....

Recommended Posts

Hello, first of all forgive my bad english. It's not my first language.
OK, let's go:
Don't be shocked but I only play GW2 with controller (xbox) using Steam. (I just love it. I think it's much better than a mouse and keyboard. And there are some tutorials on youtube if you're curious). Yesterday the art screens between one map and another were super slow and I had the kitten idea to use a program I've been calling "Smart Game Booster". This program somehow optimizes the game which ultimately runs faster.
The transition screens between maps really got faster but something (which I have no idea about) happened that caused GW2 to lose connection with Steam and now it doesn't recognize the Controller anymore. Sad to note that apparently nothing has changed. GW2 appears on Steam, Steam recognizes the Controller but the game no longer. I even deleted the "Smart Game Booster", restarted the computer 1,000 times, etc and nothing happened. Does anyone have any guesses? Perhaps some GW2 temporary folder that if cleaned or deleted could solve the problem? I've tried everything I thought of and nothing has fixed the problem. I am in that spiritual state between abstinence and despair. Thank you for your help.
Taking advantage of this topic.... There is still no news of A.NET putting the controller option in GW2?? Even the world of warcraft developers (who are the most stubborn devs in the universe) already put this option on that wagon...!

Thank you!☺️

  • Sad 1
Link to comment
Share on other sites

You can always delete GW2, and redownload everything. Delete the folder as well. There's nothing in it that would be important, everything is on the server anyway and will get re-downloaded.

However, i don't know what that program actually did.

GW2 never recognizes the controller. Only Steam does, and translates the input into KB/m commands, so if something is broken, it's with Steam. Does the in game overlay work?

Link to comment
Share on other sites

GW2 doesn't have Native controller support, either through the stand alone client or Steam.

the problem therefore is nothing to do with your GW2 installation, check our steam controller setting, maybe delete any profiles for your controllers and set them up from fresh.

Link to comment
Share on other sites

I'm using controller as well

Yes GW2 has some things that makes is very good compared to other MMO's.

Action CAM + that it automatically goes into mouse mode when going to vendor/inventory etc


... Are you sure your config is still enabled?

I've experienced it suddenly turning off after they updated to the new big picture UI

Link to comment
Share on other sites


It looks like (in a bizarre way) I've solved the problem. I had to create a copy of the controller configuration within Steam (A new "save" one) and it worked. Now I have GW2 and GW2-2 lol. And the old configuration (identifies the new one) is still there but it's dead for some reason....!

Thank you all.

p.s: A.NET plzzzzz we need a native controller system. ty.

  • Sad 1
Link to comment
Share on other sites

With Steam closed, go to:

Program Files x86/Steam/userdata/_rename_the_folder_here


See if that fixes it. I had a similar issue where steam wouldn't sync anything.

Loading screens get progressively longer the longer you play, restarting the game usually "fixes" it. Alternatively, if you feel you need a game booster, then it's probably time to upgrade or replace your computer.

Edited by Neiara.9362
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...