Jump to content
  • Sign Up

GW2 stuck at 60fps with unlimited frame limiter


Recommended Posts

35 minutes ago, Akimoto.6172 said:

I bought a laptop with 13th gen i9 cpu and rtx 4090. I used to run GW2 at max settings at 220 fps. Lately I could barely hit 70 fps at max performance even if the frame limiter is set to unlimited. What do you think is the problem? Thank you

There's supposed to be some driver configurations that also limit frame rate outside of the game.  I don't know them offhand.  I think vsync or gsync does something like that too.

Link to comment
Share on other sites

On 7/15/2023 at 10:18 AM, TheQuickFox.3826 said:

Make sure Vertical Sync (VSync) is off, both in the Nvidia control panel as in the W2 game settings. Otherwise FPS is synchronized (and limited) to the refresh rate of your monitor. Which is usually 60Hz (60 fps)

I tried turning VSync off in both the Nvidia and GW2 settings but it still averaged at 60 fps. I don't know what to do🙁

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...