Jump to content
  • Sign Up

(macOS & Linux) Fix for WINE -usecoherent issue


Recommended Posts

The previous topic specifically about -usecoherent got merged into a mega topic about DX9, so any discussion specifically about this problem got buried by people still trying to run DX9.

This is for anyone who followed the Running Guild Wars 2 With DX11 On macOS Using Wine document (though it may be a solution if you are using other WINE solutions as well).

Before the latest patch, the -usecoherent switch was required because CEF wasn't working with WINE's dxvk. There's now a workaround for this! (See the section "Tweaking Config" in the document above.)

I tried it last night & it worked for me. I seem to be back up-and-running at a playable framerate.

Edited by Gumbolia.5381
Add Linux to title
Link to comment
Share on other sites

13 hours ago, Gumbolia.5381 said:

The previous topic specifically about -usecoherent got merged into a mega topic about DX9, so any discussion specifically about this problem got buried by people still trying to run DX9.

This is for anyone who followed the Running Guild Wars 2 With DX11 On macOS Using Wine document (though it may be a solution if you are using other WINE solutions as well).

Before the latest patch, the -usecoherent switch was required because CEF wasn't working with WINE's dxvk. There's now a workaround for this! (See the section "Tweaking Config" in the document above.)

I tried it last night & it worked for me. I seem to be back up-and-running at a playable framerate.

Thanks this worked for me. With the above setup instructions my Wine installiation was getting 40-60 FPS avg.

  • Like 1
Link to comment
Share on other sites

Not sure if I should have started a new topic but it ties in with WINE and CEF.

If you are using Linux and using Lutris to launch GW2 and -usercoherent no longer works, TP not working, you need to do the following:

1) Upgrade to the latest Lutris. (5.13)

2) Right click on the GW2 icon  and select configure.

3) select Runner options.

4) From the drop box on Wine versions, select the option with 7.2 in it. (Maybe has (default) next to it.) Make sure you've deleted -usercoherent and then save. you may have to restart a couple of times before this takes but the TP then works.

WINE 7.2 is the earliest version that supports CEF and has some bugs but nothing terrible in GW2.

Edited by Gorwwen.1236
spelling
  • Thanks 1
Link to comment
Share on other sites

  • Gumbolia.5381 changed the title to (macOS & Linux) Fix for WINE -usecoherent issue

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...