Jump to content
  • Sign Up

Unable to craft some SotO decorations [Merged]

Recommended Posts

I've been trying to craft some new decorations which are released with SotO but unfortunately I'm not able to craft some of them.

Reason for this is whenever I need to use another decoration to craft one (for instance Academic Light needs a Gold Firepit) the game wants to use one from my inventory and not from the guild decarations. Everytime I craft the Gold Firepit it is automatically send to the Assembly Device, and after assembly to the guild decorations. 

The recipe for crafting the Academic Light should be using the Gold Fire pit from the guild decorations.

The following decorations all have the same problem:

Astral Ward Gate

Astral Ward Door

Astral Ward Pillar

Astral Ward Wall

Academic Light

Complete Academic Arch

Tall Academic Arch

Academic Wall with Windows

Round Academic Column

Partial Academic Arch

Square Academic Column

Academic Wall

I have not tested all these decorations but I'm assuming they are not able to be crafted now.




  • Like 3
Link to comment
Share on other sites

@Rubi Bayer.8493, I just crafted the 2 Elegant Square Pillars required to build the Astral Ward Gate, but they are not being recognized as such. When I try to craft the new Astral Ward Gate decoration, it tells me I own 0 Elegant Square Pillars, though I have 2 of them in the Decoration Storage.

Would be sweet if this could be fixed so that the new SotO decoration can be used in Guild Halls. 🙂 Thanks in advance!

P.S. Edit: Screenshots! >>> https://i.imgur.com/WJe115v.jpg  ,  https://i.imgur.com/UnCFhq9.jpg

Edited by Ashantara.8731
Links added.
  • Thanks 2
Link to comment
Share on other sites

I just tried to make the same thing for my guild. The same bug of the two pillars belonging to the guild but ME having none cropped up. I can place the two pillars. I tried every trick I know, and I've been a scribe a MONTH after it was released. Anet, could you fix this.

Edited by Tenal.1546
syntax error
  • Like 2
Link to comment
Share on other sites

I have the same issue with the Astral Ward Door, it says my guild doesn't have two elegant wall panels while I just crafted them.
It's my private guild, so I have access to everything.
I did notice a difference in the elegant wall panel description:
When making the Elegant Wall Panel it says:
"Double click to consume.
A decoration schematic that is processed by the guild's assembly device to make the decoration.
Crafting Material: Scribe (400)"
Screenshot 1

In the final step of crafting the Astral Ward Door, the Elegant Wall Panel is described as:

"Double click to consume.
A decoration schematic that is processed by the guild's assembly device to make the decoration.
Account Bound on Acquire
Crafting Material: Scribe (400)"
screenshot 2

  • Thanks 1
Link to comment
Share on other sites

I'm having the same problem. Trying to craft the Astral Pillar, but the Elegant Pillar needed to craft it is not showing up on the crafting tab., though I know there are some in storage.


Edit: A guildie confirmed the issue. He can see the elegant pillars in storage but not the astral pillar crafting tab.

Edited by Arianna.9203
added info
  • Like 1
Link to comment
Share on other sites

Let's hope they fix this in tomorrow patch, together with many other bugs and glitches discovered and reported almost every day. I had a minor rollback yesterday while in Garden Heights gathering my buffs. When I was almost done, suddenly Amnytas map loading screen popped up and I was teleported back to Amnytas with all my buffs gone. Later I heard from a few players that they experienced this rollback glitch earlier too 😦 What is happening ANet?

Edited by Sugar Min.5834
  • Confused 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...