Jump to content
  • Sign Up

WHY WHY amnytas is soo lag and fps kill


Recommended Posts

whenever turn towards the spire in middle.....even whn at the edge of map and even whn there is a wall in front of me. fps will drop by half. i tried turning off all setting one by one and nothing changes. please fix your fps and optimization. i didnt think you could make it worst. 

  • Like 3
  • Thanks 5
  • Haha 1
  • Sad 1
Link to comment
Share on other sites

For me it's not just amnytas but the whole game for the past week and a half.

Since then base ping has jumped 50-70ms and stayed there, from the looks of a tracert the main issue is on Amazon IP's (ie, the AWS game servers).

Then, on top of that, there's the sudden spikes, like what I just had. Was in WvW and a little PvE and all was fine (apart from said base increase) and so I decide to do a PvP match. The moment it started ping jumped to 1000, skills etc on constant 1-2s delay and it stay that way for the whole match (which we lost BTW, tho only just and wouldn't have if I had normal ping).

This has not been a one off, really starting to get sick of it.

  • Like 4
  • Sad 1
Link to comment
Share on other sites

4 hours ago, Dark Shadow.3291 said:

Same problem for me, especially when I look to the center of the map (RTX 4070 TI)

I don't mean to disparage or dispute your statement.I just want to add my experience:  I only have an RTX 4070 (and an AMD Ryzen 7 7700X CPU), all GW2 graphic settings on max and have stable 60fps with the map meta.

When there are many players on the map meta and I approach them, my CPU power (and CPU fan) goes to max. But my graphics card doesn't go to max.

  • Like 1
  • Confused 1
  • Sad 1
Link to comment
Share on other sites

2 hours ago, Zok.4956 said:

I don't mean to disparage or dispute your statement.I just want to add my experience:  I only have an RTX 4070 (and an AMD Ryzen 7 7700X CPU), all GW2 graphic settings on max and have stable 60fps with the map meta.

When there are many players on the map meta and I approach them, my CPU power (and CPU fan) goes to max. But my graphics card doesn't go to max.

I would love to see a video of you flying towards Amnytas center spire with stable 60fps (and shwcasing your settings at the same time).

Maybe that would give us a clue as to what the rest of us is doing wrong.

Amnytas and Kaineng City only have that behavior for me (the FPS drop).

  • Like 6
  • Thanks 1
  • Confused 1
  • Sad 1
Link to comment
Share on other sites

45 minutes ago, gousgou.5438 said:

I would love to see a video of you flying towards Amnytas center spire with stable 60fps (and shwcasing your settings at the same time).

It proves nothing for the FPS issues you and others are having.

For the sake of completeness: Win11 Pro, RTX 4070 graphics card with 4K resolution, AM5 platform with X670E chipset, AMD Ryzen 7 7700X CPU, 64 GB RAM, Samsung SSD 990 (connected via full lanes of PCIE 4 ) and 100 Mbit/s internet connection.

45 minutes ago, gousgou.5438 said:

Maybe that would give us a clue as to what the rest of us is doing wrong.

I don't think you're doing anything wrong. It's probably a bad optimization (bug?) that's more prevalent on some PCs/Clients than others.

Edited by Zok.4956
  • Sad 1
Link to comment
Share on other sites

Workaround on those maps for now is to reduce Environement setting to low. It gives a lot of fps in amnytas and some in wizards tower. FPS Drops happen there because even things obscured by other buildings are rendered, and those maps are very detailed. This setting decreases draw distance on many map elements, and makes some elements not render.

Here are images staring at the wall:

before:

https://postimg.cc/dD6KqB3H

after:

https://i.postimg.cc/htwKh2M6/image.png

 

Its still not ideal, but a bit better. Increases fps from 10% to 30% depending on location

 

Edited by lorkano.4609
  • Like 2
  • Confused 1
  • Sad 1
Link to comment
Share on other sites

I am having the same exact issue, my pc is able to run the game at 100 fps but this map is horrible. Dropping to 35 at times and its really annoying making the game almost unplayable.

 

EDIT: Adjusting the Environment settings to low almost instantly increased my fps to 60-70.

Edited by iLegion.3597
  • Like 1
  • Confused 1
  • Sad 1
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...