Jump to content
  • Sign Up

Echoes of the Obscure achievement stuck [Merged]


Recommended Posts

I have all items to craft Turai's Artifact, but Essence of the Obscure can't be placed in Mystic Forge and not listed in list of available items.

I have deleted first Essence of the Obscure but when I bought second one I can't use it.

https://pasteboard.co/ysKC1ft24uOD.png

https://pasteboard.co/rYlwFlre7mUE.png

Edited by Jampire.4593
  • Like 1
Link to comment
Share on other sites

7 hours ago, Septimus.4972 said:

I'm bumping this cause I posted about this same problem I had as well. I got rid of the essence to make room in my inventory, bought it again and tried to make it but it wouldn't show

Same behavior for me. I have deleted first essence thinking it's not needed anymore but when I bought second one it's cannot be used in mystic forge.

@Rubi Bayer.8493  please have a look at this problem 😳

Edited by Jampire.4593
Link to comment
Share on other sites

@Rubi Bayer.8493 Attempting step 5 of the Echoes of the Obscure collection gives another Echo of Turai instead of Turai's Artifact.

Also, when I unlock the Eternal Blade skin, it unlocks Item ((1090890)) instead. I cannot find the skin in my Wardrobe under "Eternal Blade" but under "((1090890))".

Edited by Ashantara.8731
  • Like 1
  • Confused 1
Link to comment
Share on other sites

@DeadlyKharn.7816 Did you mean "Echo of the Obscure" ? Because it is not an item that appears in your inventory.
"Essence of the Obscure" can be bought from the Astral Ward Protector near the Bastion of the Obscure Waypoint.

The issue we're having is that the first item in the collection, "Essence of the Obscure" does not show up as an option when combining the materials (Essence of the Obscure, Echo of the Past, Echo of Turai, Ossa's Crusader Inscription) to form Turai's Artifact in the Mystic Forge interface even if we have the items in our inventory or bank.
 

Update: I was able to forge the recipe after receiving a replacement "Essence of the Obscure" with the help of a friendly Customer Support Rep. I recommend this in lieu of waiting for a fix.

Edited by Suffen.5078
Update on status of progression wrt Bug/Issue
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 9/19/2023 at 11:01 PM, One Sassy Cat.3094 said:

New issue... I put all the items into the forge and it worked. Got the achievement for the collection and everything. Yet there's no item in my inventory so I can't complete the quest.

I had the very same issue and was actually in contact with the support about this. Turns out, it is just a UX bug:

While the preview of Turai's Artifact in the Mystic Forge success message makes it look like it would be an actual inventory item (when hovering over its depiction inside the message it has a thumbnail, a description, an item code and even a selling price), it is apparently intentional that it never materializes inside the player inventory. Maybe it was originally planned to be an actual item instead of a non-physical token, but then they changed their minds to prevent cases where people would accidentally salvage or delete it, but forgot to change the item description accordingly to underline that change, so now it confuses everyone as we start rummaging through our inventories and wonder where the kitten the item went.
Then again, it might still be the case that the item not showing up is an actual bug, of course, but in that case it isn't one that blocks progress.

I first assumed it would block progress, though, because of a second severe UX issue:

Upon interacting with the Heart of the Priorty HP, I just saw the prompt to fuse 25 Quartz Crystals into a Charged Quartz Crystal and assumed the option to perform the final achievement step wouldn't show up because I lacked the item in my inventory. But it turned out that the code for the HPs that checks achievement conditions just suffers from faulty prioritization:
Instead of showing the achievement-related option first when conditions are met, the quartz-fusing option always takes precedence. So I went to the bank, withdrew 25 Quartz Crystals, fused them and upon the next interaction with the HP I was able to complete the collection.

Good luck to all Non-Veteran players figuring that one out by themselves. I mean, not having any Quartz in your posession being an actual blocker for achievement completion? That is so absurd, one probably couldn't make it up even if one tried.

It even took me  quite a while and various interactions with support before it dawned on me and I actually pride myself of posessing a relatively experienced developer brain... But then again, maybe that was exactly why I figured the bug must be more severe than it actually was in the first place, because I'm used to digging deeper and assuming the worst when it comes to bugs, so who knows.

In my opinion, the HP special interactions need a rewrite to always prioritize achievement-related interactions before the Quartz fusion, that's just basic good UX. And Turai's artifact needs an update, so that its description clearly marks it as non-physical, to avoid any further confusion.

Edited by Sigmus.3862
Typos
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...