Jump to content
  • Sign Up

Couldnt complete / leave epilogue of chap. 10 Treachery


Recommended Posts

Hey guys 

Just did the last part of Treachery 

Spoiler

after killing Cerus with Peitha and returning to the wizards tower

I listend to the necessary story parts in the epilogue and could have leave, if i wanted to. 

The "leave" Button was there and clickable.

But i decided to do the "A chapter closed" achievement first. i talked to all of my friends there (last one was second time zojja). Right after the achievement was shown as completed, the "leave" button disappeared and i was not able to leave the instance anymore. havnt find a green "teleporter" out of the instance either. tried to logoff, played the whole epilogue again, talked only to the necessary ones, "leave" button did not appear.  

Tried to port out of the instance, same again, log says i should play the story and head back to the wizards tower. 
I really dont want to hear all their phrases _again_ just to see that the chapter is still open.

i dont have a screenshot of the missing button, dont make me do it again just for the screen, pls. 😄
Just imagine a comleted story without the leave button above the mini map.

 

 

  • Confused 1
Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...