Jump to content
  • Sign Up

Skyscale Egg Infusion (Skyscale of Water - Bloodtide Coast)


Recommended Posts

I am trying to complete my Skyscale of Water Egg infusion and I seem to be running into a bug.

The first time I went to the location (Bloodtide Coast), I unknowingly had Quartz Crystals in my inventory and was asked if I want to charge them. I did. Then I tried to use the "place of power" again and was given a message "You've gained all you can from this place of power." I thought - no big deal this must have to do with the 24 hr infusion limitation for charged quartz, I will come back later. I have now tried back about a dozen time over a three day span and I continue to get the same message. This is the last of my eggs to infuse and is blocking my progression to a beloved Skyscale. Please help!

Has anyone run into a similar issue or have any advice / solutions?

  • Sad 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...