Jump to content
  • Sign Up

P-Core clocks drop massively only when running GW2


Recommended Posts

I am running a 14700K with an MSI board and Gameboost enabled. P-Cores are set to max boost at 5.7 and E-cores at 4.4. For some reason anytime I start this game, the P-core clocks drop to 3.5 and never go any higher even after exiting the game. E-cores are not effected and staying at 4.4. I am not having this problem when running any other games. The only ones I have tried are Forza and Halo infinite, both running fine.

Link to comment
Share on other sites

I wouldn't expect such an old game to have been written with the latest CPU technology in mind.  GW2 hits CPUs rather hard compared to other games and the fact that you're seeing the P-Cores affected and not the E-Cores makes sense since P-Cores take on the traditional CPU function.  I'm not so familiar with the Intel CPU tech.  What happens when you don't overclock the cores?  And you're using Win11 for this, right?

Edited by Chaba.5410
Link to comment
Share on other sites

11 hours ago, Murder Max.4326 said:

the P-core clocks drop to 3.5 and never go any higher even after exiting the game.

This does not make sense (in terms of does not look like a GW2 specific issue) because when you exit the game it can't affect your CPU anymore. Maybe some CPU control software or driver gets stuck, when you play GW2.

Link to comment
Share on other sites

19 hours ago, Murder Max.4326 said:

I am running a 14700K with an MSI board and Gameboost enabled. P-Cores are set to max boost at 5.7 and E-cores at 4.4. For some reason anytime I start this game, the P-core clocks drop to 3.5 and never go any higher even after exiting the game. E-cores are not effected and staying at 4.4. I am not having this problem when running any other games. The only ones I have tried are Forza and Halo infinite, both running fine.

Disable or remove Gameboost.

 

From what I can read here it sounds like does too many changes on your computer without you knowing what those are and what they can impact.

https://www.techspot.com/downloads/675-gameboost.html

Try again and test the same scene where this happened in game to see if there is any change. Maybe you need to re-install windows to have clean install without all changes in MS Windows registry.

Also make sure that temperature isn't impacting CPU (down clocking) or that you have set anything in BIOS/UEFI that might have the opposite effect from what you think it should. Make sure RAM speed (XMP) is set to match IMC (Integrated Memory Control) and you are running memory in Gear 1.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...