Jump to content
  • Sign Up

Can't use Wizard's Vault and BL Trading Company

Recommended Posts

That 2 section of game i can not use it. Only if i use vpn.It's been start happenning from last update. Since that update i cant use them. When i open the windows its not loading. Tried everything but not worked till i use VPN. To mention this problem for open a topic went to forum also forum login screen couldnt load. VPN also didnt work there because of autotancition. After i login details i am gettin autantication code like normal thing. But when i enter the code it always say wrong or other kind error that "details are not corretct." Finally today it today login screen start working and i able to mention the problem. Other problems still continue. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...