Jump to content
  • Sign Up

HIGH LATENCY in South East Asia [Merged]


Recommended Posts

From SG? It's normal and ANet does not have a solution. My fix would be, use a VPN to connect to a US IP and hope you don't connect to one that the RMT-ers have connected. Otherwise your account will be locked. Goodluck!

The issue is within the cheap Amazon Cloud Servers that ANet is using. They keep putting the blame on my ISP provider when this issue has been happening in GW2 for years.

Edited by Kera.3982
  • Like 3
  • Confused 1
Link to comment
Share on other sites

I was forced to buy VPN 2months ago because it was simply unplayable during prime sea time especially in WvW and all the way till now has been consistently hearing from guild mates and friends about lag. Just tonight my wvw guild had to cancel mid run because half the squad can't play the game. Like seriously anet?

 

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Why did you buy a VPN? Just use a free one and acknowledge ANet Support you're using a VPN for your account.

GW2 uses Amazon Cloud Servers. The same cheap cloud servers SWTOR uses. Unfortunately Support will not help you with this issue. But you might not wanna pay for a VPN and use a free one instead.

  • Sad 1
Link to comment
Share on other sites

On 7/13/2024 at 6:50 PM, Kera.3982 said:

Why did you buy a VPN? Just use a free one and acknowledge ANet Support you're using a VPN for your account.

GW2 uses Amazon Cloud Servers. The same cheap cloud servers SWTOR uses. Unfortunately Support will not help you with this issue. But you might not wanna pay for a VPN and use a free one instead.

What free one?  

AWS servers give me 300+ ping from SEA to NA from GW2, where as I only get 140ms using AWS SWTOR servers to Sydney.  Maybe Anet needs an AWS server in Sydney for us SEA players as well. 

Link to comment
Share on other sites

On 7/10/2024 at 4:43 PM, Kera.3982 said:

From SG? It's normal and ANet does not have a solution. My fix would be, use a VPN to connect to a US IP and hope you don't connect to one that the RMT-ers have connected. Otherwise your account will be locked. Goodluck!

The issue is within the cheap Amazon Cloud Servers that ANet is using. They keep putting the blame on my ISP provider when this issue has been happening in GW2 for years.

Same problems here.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...