Jump to content
  • Sign Up

DCOM Related Game breaking bug with latest windows update (KB5040442) "Unable to Initialize 3D Output"


flycken.3182

Recommended Posts

Woke up and noticed the game wasn't working today, and got the "Unable to Initialize 3D Output", with references to DirectX11 and graphics drivers as the likely culprit.  Here's what I did, and my eventual (temporary) solution.

Things I did to troubleshoot:
-Updated Nvidia Drivers (I'm running a newish HP Victus gaming laptop with a 4060 inside)
-Made sure DirectX 11 was up to date, but it hasn't been updated since 2021 so I was pretty sure that wasn't it.

Neither of these fixed the issue, so I was left to look at the only other thing that changed.  That being windows updates from "patch tuesday" (yesterday).  I uninstalled the July cumulative update (KB5040442) for windows 11, and after reboot, the game runs FINE now.  I'm letting others know, and possibly hoping to alert the dev team in case this is a larger issue that affects them.  I don't believe the driver update or DirectX 11 updates had any effect on anything, I think the latest windows update that installed overnight is the likely culprit.  Happy gaming yall!

Edited by flycken.3182
punctuation and clarity
  • Like 2
  • Sad 1
Link to comment
Share on other sites

I tested myself:
Windows 11 Pro x64 with July cumulative update (KB5040442) installed that brought to build version 22631.3880 for Windows 11. Have Nvidia Geforce RTX 4060 Ti 16GB here with the Geforce Driver 551.61 WHQL that worked fine. Later updated to Geforce Driver 556.12 WHQL worked fine for Guild Wars 2 too.

My system:
AMD Ryzen 7 7800X3D at stock.
64GB DDR5-5200 JEDEC RAM
Gainward Panther Geforce RTX 4060 Ti 16GB at stock (NV reference clock).
Windows 11 Pro x64.


So... Flycken.
Do you has your iGPU active? If yes. Make sure the iGPU driver is update as well.
 

  • Confused 1
Link to comment
Share on other sites

I do appreciate the update, I do have an iGPU as well, though it should be disabled and not used for GW2.  I decided to update it anyways, and after doing both the latest update as well as the intel graphics driver.  It still gives me a "Unable to Initialize 3D Output" error and does not load.  looking at the event log to see if there's any pertinent info, as I am not seeing many others has having this particular issue.

  • Sad 1
Link to comment
Share on other sites

  • flycken.3182 changed the title to DCOM Related Game breaking bug with latest windows update (KB5040442) "Unable to Initialize 3D Output"

The error appears to be related to the dcom events that continually pop up when trying to run the game (event 10010) initializing  Windows.Gaming.GameBar.  But after following down that rabbit hole and running SFC and a few other health related commands, uninstalling xbox overlays, and reinstalling the gamebar, I found that this latest update actually addresses a DCOM CVE (CVE-2024-38061), and that there was some DCOM hardening that went into this latest update.  Not sure the differences between my model and yours, but I suspect there are some issues with this latest release from microsoft that likely affect certain installations/HW configurations.

  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...