Jump to content
  • Sign Up

Game alt-tabbing or flashing desktop [merged]


Recommended Posts

  • Replies 465
  • Created
  • Last Reply

Top Posters In This Topic

@X T D.6458 said:

@X T D.6458 said:To the people who have rolled back or are intentionally holding back on installing the new windows update, its usually a bad idea to do so. These updates often contain security features and patches, and you can leave your computer vulnerable for the sake of convenience. Better to put up with this bug for now rather than putting your computer and personal safety at risk.

I'll wait for the next update in June.

Oh its fine, I have a premium firewall/AV and i dont go clicking on everything in my inbox or the darkweb.

I cant remember a single time in the last 10-15years that ive been infected by some malware or virus.

Erryting gonna be alright, Erryting gonna be Ok, so dont worry, about a thing. -- as Bob Marley would say

Link to post
Share on other sites

Wanted to add my comment as well, because my experience is a bit different. I have been having flickering to desktop for a moment during loading screens since I started playing last year. But it was a very minor issue, didn't bother me at all, so I didn't do anything about it assuming that it was normal. But since the last Windows upgrade this issue worsened considerably. Now that flickering happens for the whole duration of the loading screen, it looks like the game just crashed, also it made my loading screens way longer than they were. I'll try disabling the focus attention feature. But my main point is that this is not new for me and has been happening (although minor as it was) for more than half a year.

Link to post
Share on other sites

So after telling me you didn't get the info you requested twice you just close my ticket and ask me to fill out the survey. Did nothing at all to try resolving my ticket. Telling me to just play Windowed and maybe it's Discord is not fixing my issue nor was it an attempt to work on it. Put in a ticket they said, yet they won't even attempt to resolve the issue.

Link to post
Share on other sites

Turning off the focus assist feature in win10 seems to have fixed this issue for me, and I was able to go back to fullscreen from windowed fullscreen. Started getting this same thing happening (the minimizing) once the new win10 update hit me yesterday. Game didn't minimize when I switched to windowed fullscreen mode, but did in fullscreen mode.

Link to post
Share on other sites

This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

Link to post
Share on other sites
  • ArenaNet Staff

@"Rayti.6531" said:This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

Link to post
Share on other sites

@"Rayti.6531" said:This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

I'd previously disabled the focus assist when playing a game option and although it did make the showing of the desktop quicker, it didn't fully resolve the issue. But now when I added that second piece of checking that box to disable full screen optimizations, it did indeed appear to resolve the issue. Now when changing maps it quickly flashes a black screen, but doesn't flash to the desktop any more. Thank you for passing along that tip!

Link to post
Share on other sites

@GM Magister.8736 said:

@"Rayti.6531" said:
suggestion from "eragon03" on reddit fixed it for me.
  • In case you enabled it when asked for it after the last Win 10 update:
    DIS
    able the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

You're welcome. Hope it helps :)

Link to post
Share on other sites

@"Rayti.6531" said:This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

I tried this just now, checking disable fullscreen optimization does nothing to help. The notifications option did not help either as every time I restarted the application the focus assist settings would go from off, back to priority only. This did however lead to a "fix".

I had originally disabled focus assist in the windows settings, but had left other tabs turned on within the settings (see screenshot/attachment). After also disabling the "During these times", "When I'm duplicating my display", and "When I'm playing a game" options, I no longer dropout to desktop for more than a quarter of a second at best. Not entirely fixed but I went from waiting 5-10 seconds at the desktop and flashing in and out, to a quick .25 sec flash back into the loading screen and or the map already.

http://i16.photobucket.com/albums/b19/rv8080/focus%20example_zpspgk24gkt.jpg

Link to post
Share on other sites
  • ArenaNet Staff

Hey there. I'm not exactly sure what took place in the one extended conversation in this thread, but I want to share some insights on attachments. People occasionally try to send me files, images, reports, etc., through our e-mail or ticketing system, and it's important for you to know that our system is set up to not accept or allow attachments to come through in the first communication within a ticket.

What you can do is this:

  • Submit a report and tell the agent that you have a report, file, or something else that you are able to forward.
  • The agent will respond to let you know that they want to receive the attachment.
  • You update your ticket and include the attachment.
  • The agent then should receive the attachment just fine. If within a few days you don't receive a response that indicates that they have received the attachment, you are welcome to update the existing ticket to inquire whether it was received. This confirms we're fully communicating with one another and ensures that CS knows that you have a file (or sent a file) and lets them determine whether to ask for it to be sent again. (And hey, if this is a bit of a bother, we apologize, but it really is the most secure system we have at present.)

Thanks for working with us to use best security practices and to get you the help that you need!

Link to post
Share on other sites

@Orion Templar.4589 said:I'd previously disabled the focus assist when playing a game option and although it did make the showing of the desktop quicker, it didn't fully resolve the issue. But now when I added that second piece of checking that box to disable full screen optimizations, it did indeed appear to resolve the issue. Now when changing maps it quickly flashes a black screen, but doesn't flash to the desktop any more. Thank you for passing along that tip!

I get those short black flashes as well, but I think I‘ve had those prior to the 1803 update as well (at least with one of the past few GW2 client versions). So I guess that‘s as close to „normal“ and as good as it gets for now...

Glad it worked for you as well.

Link to post
Share on other sites

@"Rayti.6531" said:This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

Man I had high hopes this would fix it but the option was already checked so no good. Disabling the other new option recommended early in the thread shortened the flash to a second or 2 but this started today as soon as the windows 10 update completed.

I also have had the black flashes ever since building the new pc 6 months ago during gw2 loads. I guess those didnt bother me as much as this did but I hope they figure this out soon.

Link to post
Share on other sites

@GM Magister.8736 said:

@"Rayti.6531" said:
suggestion from "eragon03" on reddit fixed it for me.
  • In case you enabled it when asked for it after the last Win 10 update:
    DIS
    able the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

Tried that and it made no difference. Request #6905676.

Link to post
Share on other sites

Little update on my end: the problem seems to have reduced and almost completely disappeared. I haven't done anything different, but I don't recall having this problem while playing fractals with my guild for the past few hours. The problem was still there before midnight (GMT+8) but past midnight it seems to have cleared up. I'm not sure if this was because something had been fixed or not

Link to post
Share on other sites

I kinda fixed the problem. SO for windows 10, go to the "New notification icon on the bottom right corner of the desktop. Close out the cortana Kitten. MAke sure that it doesn't pop up again. IT helped me. It still alt tab back to the desktop, but for 1 millisec. Unlike before, it alt tab and i had to wait like 10 sec to get back on the game.

Link to post
Share on other sites

Ok So I know that people have said Focus Assist was the problem. Many of us already had it turned off so how could that be the problem right? Well although mine was already off , and I'd even toggled it to see if it would fix it. It didn't, but then I left it off as always but this time I unticked the "WHEN I"M PLAYING A GAME' option, it seems to have fixed the issue for me. Loads right up now, and I was getting flashes every 3-4 mins, those flashings may have also been fixed. Didn't get a flash while I tested for 10 mins. Will be back in about 30mins to confirm the fix.

UPDATE: Well although it loads right in, and I don't flash anymore during game play. It now will cause the screen to get stuck if I alt tab. I then have to end GW2 per task manager. guess I'll log back in to WoW, or Swtor then. Have a good night everyone.

Link to post
Share on other sites

Disabling fullscreen optimizations seems to have gotten me very close to a fix as well. I now usually get only the quick switch to a black screen when changing maps, though I will still very occasionally get a split second flash to the desktop. Still a great improvement over the situation as it stood just after the win 10 update . . .

My next natural question is what are fullscreen optimizations and do I want them disabled? :p

Link to post
Share on other sites

I have the same issue with Windows 10, it updated Thursday night and since then, when i run GW, or change maps in GW; it flashes back to desktop. Has frozen twice from alt-tabbing. And when I logged into GW2 i noticed that my ping, for a moment would be a crazy number like 1.5k or 3k.

I turned off the notifications but the 'flashing back to desktop' still happens, just to a lesser degree. I notice in the top left hand corner it shows a "GW2" title bar as if from a window.

I blame windows 10 entirely.

Link to post
Share on other sites

@"Gop.8713" said:My next natural question is what are fullscreen optimizations and do I want them disabled? :p

Full screen optimization is supposed to improve performance while gaming. It works for some games, but for others it actually makes matters worse, decreases your FPS or can lead to other strange bugs (see the current problems with GW2).

Microsoft claims that they work on improvements of this feature continuously, so I guess one of the recent improvements went sideways with some setups/combinations of software in use (these things are difficult to track down).

It is enabled by default, so I’d suggest to keep it that way system-wide and just try to disable it for games you're experiencing problems with.

Link to post
Share on other sites

Hi all,just experienced the same problem after Windows 10 April Update here in Germany some days ago. Turning off this focus assist settings in windows solved the problem in parts because I only dropped back to desktop for only 1 second (before it was around 5-6 seconds). Now a guildie gave me this tip: In the GW2 ingame graphics settings I changed my resolution to "Windowed Fullscreen". Now the problem has entirely disappeared.

Link to post
Share on other sites

@"Rayti.6531" said:This suggestion from "eragon03" on reddit fixed it for me.

  • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
  • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

That made it worse for me. With the fullscreen optimisation disabled, I get multiple black flashes when I wait for the game to load after logging in, AND when I change maps or load a character, I get bounced to the desktop, then there's a flash of black screen, then the desktop, then the character loads into the new map.

With fullscreen optimisation active ("disable" checkbox OFF), I don't get the extra black flashes.

Link to post
Share on other sites

@Wevie.8972 said:I blame windows 10 entirely.

I wouldn't automatically blame Windows 10 / April for this. It could easily be GW2 that's doing something wrong that the previous builds of Windows tolerated better than April does. (There was a similar thing on iPhones - Apple released an update to iOS that made it less tolerant of a particular bug in apps, so those apps started crashing out and/or freezing. You'd think that was Apple's fault entirely, but the apps were buggy, and were doing something that the developer guides said not to do.)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...