Jump to content
  • Sign Up

Bow String Issues with Weapon Swap and Mounts [Merged]


Recommended Posts

  • 1 month later...
  • Replies 56
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

bug still not fixed. but there seems to be a work-around.if you hide your bow by unchecking the box the bow strings wont disappear if you attack with your mount. i believe this is because it re-rende

  • 1 month later...

OT: Appreciate the merge! That's far more convenient than the two threads that I had going. I had made the new one because it began as a different issue at the start of the year and this particular issue has persisted until now. Having everything all in one place makes it easier to track and document. Thanks again.

Link to post
Share on other sites

@CETheLucid.3964 said:OT: Appreciate the merge!

having your threads merged is a good sign :)... means someone or a mod took notice of your concern and probably relayed it to the devs or something..

that said, yeah this bug has been annoying me whenever i go on my ranger or use shortbow on my thief. but after a while i forget the bug exists especially when doing meta stuff and you get busy with all the enemies and players on your screen and the constant mounting+mounted skill usage

mounting and dismounting (not using skill) seems to fix it for me temporarily (until i use a mount attack skill again)

Link to post
Share on other sites

@Astyrah.4015 said:

@CETheLucid.3964 said:OT: Appreciate the merge!

having your threads merged is a good sign :)... means someone or a mod took notice of your concern and probably relayed it to the devs or something..

that said, yeah this bug has been annoying me whenever i go on my ranger or use shortbow on my thief. but after a while i forget the bug exists especially when doing meta stuff and you get busy with all the enemies and players on your screen and the constant mounting+mounted skill usage

mounting and dismounting (not using skill) seems to fix it for me temporarily (until i use a mount attack skill again)

Yep. Same here. After a while I get over it. I played GW1 for a few years so that was the standard. It's just once you have a nice thing and they even went out of their way to do neat effects for some bowstrings, it's a shame that it's broken now.

But I understand it's a small quip at the end of the day and there are bigger more pressing bugs to deal with. I'm grateful at least that it's getting attention. I intend to keep this thread updated until it's finally fixed.

Which as of the latest update remains an issue. :bleep_bloop:

Link to post
Share on other sites
  • 2 weeks later...

@Jasper Defthand.3018 said:Anet still refusing fix are they?

Not so sure it's them sneering at us mere mortals and refusing to fix the bug so much as it being a nuanced issue or else an issue of priority. The initial issue of this bug where bow strings would break on weapon swap was fixed relatively quickly if you read up.

The issue now is it breaking with mounts, particularly engage skills. If you play WvW, PvP, Fractals, any content where you can't use mounts you'll notice your bow string isn't breaking.

It remains an issue as of the latest update.

Link to post
Share on other sites
  • 2 weeks later...

@CETheLucid.3964 said:

@Ydeirt.3905 said:With the latest wintersday patch, we still didn't get any fix. The only time when they aren't breaking is when you use a different colored string (e.g plasma bow, forged bow, etc.)

Just tested it myself, they still break with colored strings. Bow strings still break with mount engage in general. Issue remains.

That's quite strange, I use forge long bow and plasma shortbow for months now and had none of these issue. I just switched to sunless greatbow when I noticed this issue. Anyhow, this issue still need a fix. It's quite immersive breaking when this happens.

Link to post
Share on other sites
  • 4 weeks later...
  • 4 weeks later...

I can confirm, the bug is still here when you use your mount engage skill the blow string will disappear, also it doesn’t matter that you swap to your other wep slot, when you use your mount engage it will disappear regaldless that you switch to the second wep slot, BUT you need to switch to the bow wep slot then mount for it to be fixed!!!or unequip then equip the bow to be fixed.

wtf is Anet doing??? it is clear that the bow strings disappear when using mount engage, way had they not fix this!?!?!?!

Also, I was suprised to see that my bow has an string!!! the reason is that I always use mount engage at every oportunity so imagine my suprise that my bow had STRINGS!!! when I had play with the bow for almost 3 weeks!!!

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 5 weeks later...
  • 2 weeks later...

This is still an issue as of the latest update. Per previous post, I do get instances where it works and I end up keeping my string after an engage but it's a random thing that I can't reliably recreate and it's almost as certain to break on the next use. This didn't used to happen before so I know they're trying.

I'll note that if I engage with my melee weapon set equipped and then swap to my bow sometime later in combat, the string will always be broken. If I engage with the bow equipped, the bow string will be broken maybe 95% of the time with a 5% chance of it actually staying in recent times.

Crazy buggy bow strings. :bleep_bloop:

Link to post
Share on other sites
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...