Jump to content
  • Sign Up

Can't run GW2 due to new monitor


Recommended Posts

I really don't know what to say about this in terms of details. I got a new monitor to use for my PC. It can also be used as a TV for cable-box and such but I don't know if that has to do anything with my problem. The point, ever since I've started using this new monitor, whenever I click PLAY on the launcher window, the game never opens nor launches. Technically, it DOES open, but for a split second and then it closes.

To make things more annoying my other games and MMO open/run just fine so... I don't know why Guild Wars 2 is any different/special.

Link to comment
Share on other sites

@"Inculpatus cedo.9234" said:You can trying using the -windowed Command Line Argument to see if that alleviates the issue. And/or disable any overlays or 3rd-party programs such as Discord, graphics card programs, etc.

https://wiki.guildwars2.com/wiki/Command_line_arguments

Good luck.

Thanks, though I will have to talk to a friend for help as I really am bad with computer-related things, and commands also scare/worry me about breaking the game even further.

Link to comment
Share on other sites

It's possible that your old monitor (and Guild Wars) was set to a resolution or refresh rate that your new monitor cannot handle. Try this to reset your graphics configuration:

  1. Open Windows Explorer (click Start, then type "Windows Explorer").
  2. In the address bar of Explorer, type "%appdata%\Guild Wars 2" and press enter.
  3. Right-click the file local.dat, then click Delete.

That will reset your graphics and sound settings (along with your email and password on the launcher, if you chose to save them.) The next time you start the game, it should re-detect your screen resolution, then you can further adjust your graphics options it in-game.

Link to comment
Share on other sites

:+1: @ Maximus Delion.8719

Also, make sure these things are set properly:

  • Your monitor is connected via DVI cable.
  • You installed the proper driver for your new monitor.
  • You set the correct refresh rate in both, your GPU settings (e.g., nVidia Control Panel) and in-game after executing what Maximus wrote.
Link to comment
Share on other sites

Thanks everyone for the support. I have found a solution that didn't occur to me till later that night. it was apparently the resolution that was not letting the game run or start. I decided to use the resolution of the old monitor and now the game is running. I adjusted the resolutions of the game too to hopefully prevent this again.

Why resolution would impact or prevent me from playing I will never understand, but again, that's why I'm no computer expert and need help with these things.

Link to comment
Share on other sites

@Arekusu.2864 said:Thanks everyone for the support. I have found a solution that didn't occur to me till later that night. it was apparently the resolution that was not letting the game run or start. I decided to use the resolution of the old monitor and now the game is running... the only draw back is everything on my monitor looks smaller, but I guess I can adjust that.

Please do as people have told you. You are basically putting a bandaid on an infected wound -- not a good idea. Solve the problem, don't try to find workarounds.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...