Jump to content
  • Sign Up

Blazing a Trail completion not possible

Recommended Posts

Discovered a weird bug with the story act "Blazing a Trail" - further progression not possible.

Seems like the part "Meet with Zalambur in his office" is bugged. Played this part with a friend. I hosted the instance but after finishing the instance my friend didn't get progression and I stucked too (didn't get the next target "Find a clear signal to communicate with Taimi" - Game only shows ever task as done (green check mark) but no new target). We tried to repeat the instance. This time my friend was the host. After successfully ended the instance, still he didn't get progression. So he is stucking at this story part.

Next try was to repeat the whole chapter. Bug occurs again but this time (games shows open tasks) we got to the part with communicate with Taimi and can continue. Weird...

Link to comment
Share on other sites

@RoyHarmon.5398 said:It happened to me today, too. My wife was "driving" the instance, and now I'm stuck. I guess I'll have to start all over.

Update: I repeated the chapter this morning, solo, and it worked just fine. It even remembered what I had chosen in the first playthrough. I was relieved that I didn't have to start the whole storyline over, because playing through the first chapter again would have made the glitch more frustrating.

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...