Jump to content
  • Sign Up

final straw


Recommended Posts

@balmyard.2064 said:well after 2 years of tring to install the game to no avail and after trying all solution I can safely say I had enough, tggough the new expantion will solve the instalation problem.what can I do? spend my money on other games :)

That sounds like a smart plan to me. Hopefully they will have an installer that works for you. Best of luck.

Link to comment
Share on other sites

@"Ashantara.8731" said:How can you have trouble installing a game? Running it, yes, but installing? :oAre you on a non-Windows OS per chance?

In my experience, users of a non-Windows OS are much less likely to have strange problems like this. macOS is hardly without fault, but "randomly doesn't work" is rarely one of them, and Linux users are ... already special advanced snowflakes to start with.

I honestly assume that it is people doing things like logging in with the "administrator" account, or having really odd permissions problems because they did something ... ill advised, because someone somewhere said to do it to "fix" some problem, or whatever, or because they ran the thing as administrator explicitly, and now don't have write permissions to the install directory, or whatever.

Most of the time that turns out to be true: the obscure problem hitting some random user is either hardware/network related, or it is some local configuration badness of some sort.

I have also learned that these are somewhere between difficult and impossible to solve on forums, which is sad: I like helping people, but I don't believe it is possible in most of these cases. Especially when the issue has persisted for two years, strongly suggesting that it is unlikely to ever be resolved without someone local diagnosing and fixing it, because the problem scope is "anywhere on the system at all".

Link to comment
Share on other sites

@SlippyCheeze.5483 said:

@"Ashantara.8731" said:How can you have trouble
installing
a game? Running it, yes, but
installing
? :oAre you on a non-Windows OS per chance?

In my experience, users of a non-Windows OS are much less likely to have strange problems like this. macOS is hardly without fault, but "randomly doesn't work" is rarely one of them

That is not what the OP said. They said that they couldn't get the installer to run (or run properly) in two (!) years, and that can happen for games that have been made for Windows OS and then "ported" to other operating systems. However, I believe most bugs the Mac client used to have have been fixed by now.

Anyway, I find it rather curious how one can manage to not get an installer to work at all.

Link to comment
Share on other sites

@"balmyard.2064" said:what can I do? spend my money on other games :)

Well, you could tell us what your issue is, and someone from this EXTREMELY HELPFUL community could try to assist you.

Or, you could just post a vaguely-generic-yet-snarky "goodbye cruel world!" message and scamper off to "spend your money on other games", while the other 6.999+ million of us who have successfully installed and played Guild Wars 2 will -- at best -- give an indifferent shrug and possibly post some variation of "okay, don't let the door hit you on the *** on the way out."

The first option tends to produce more fruitful results, but the choice is ultimately yours...

Link to comment
Share on other sites

I'm running windows 10 I've triple checked that all of my drivers are up to date.from the start the installation was rocky, the download was slow and always went from 6m/s to 2b/s then after it was done I had 1 file left but it say that I downloaded 100% (the 100% showed even when I had 900 or so files to download) and after 3 seconds the "1 file to download" was gone it still showed me 100% but when I pressed the play button it did nothing (I did the run as admin, changed language, deleted local, repaired the launcher, I can't tell you how many times I've deleted and reinstalled), after I changed the language the play chevron on the download bar was at the very beginning of the bar it say I need to download 28k more files and again it gets stuck at 100% and 1 file I've tried everything the support suggest (which is only to delete the local and restart com and to change language) and a few ideas of my own (like turning firewall and antivirus of close all non essential programs off). the problem started with the last expansion and the only thing that I didn't do that I could think of is buying a hard copy but after I threw my money on the last expansion and didn't even played it I'm not going to do that.mind you after I had no result with this game I've installed tera with no problems (took me an hour to download and install where GW2 took me 3 hours just to download its not one time thing).

Link to comment
Share on other sites

@"SlippyCheeze.5483" said:I honestly assume that it is people doing things like logging in with the "administrator" account, or having really odd permissions problems because they did something ... ill advised, because someone somewhere said to do it to "fix" some problem, or whatever, or because they ran the thing as administrator explicitly, and now don't have write permissions to the install directory, or whatever.

I run as admin only after my 4th reinstallment and I didn't touched the permission

Link to comment
Share on other sites

If you're getting stuck downloading files, a problem GW2 has is it being very susceptible to interference. In general, people with this problem need to use a VPN. TunnelBear is a popular choice, while supports recommends proXPN.

@balmyard.2064 said:the only thing that I didn't do that I could think of is buying a hard copy

It doesn't come with a disc, or at least not one you could use.

Link to comment
Share on other sites

@"balmyard.2064" said:I'm running windows 10 I've triple checked that all of my drivers are up to date.from the start the installation was rocky, the download was slow and always went from 6m/s to 2b/s then after it was done I had 1 file left but it say that I downloaded 100% (the 100% showed even when I had 900 or so files to download) and after 3 seconds the "1 file to download" was gone it still showed me 100% but when I pressed the play button it did nothing (I did the run as admin, changed language, deleted local, repaired the launcher, I can't tell you how many times I've deleted and reinstalled), after I changed the language the play chevron on the download bar was at the very beginning of the bar it say I need to download 28k more files and again it gets stuck at 100% and 1 file I've tried everything the support suggest (which is only to delete the local and restart com and to change language) and a few ideas of my own (like turning firewall and antivirus of close all non essential programs off). the problem started with the last expansion and the only thing that I didn't do that I could think of is buying a hard copy but after I threw my money on the last expansion and didn't even played it I'm not going to do that.mind you after I had no result with this game I've installed tera with no problems (took me an hour to download and install where GW2 took me 3 hours just to download its not one time thing).

Try using a vpn. For it looks like some file got corrupted wich usually makes it stuck vpn will fix this

Link to comment
Share on other sites

@"balmyard.2064" said:I'm running windows 10 I've triple checked that all of my drivers are up to date.

Well, there's the source of your problem: Windows 10. It's a bumpy OS with unwanted updates that are being forced upon the user. With each update come new issues with a variety of games.

after it was done I had 1 file left but it say that I downloaded 100% (the 100% showed even when I had 900 or so files to download)

The files are ALL being stored in the Gw2.exe (or the Gw2-64.exe). There are no separate single files. That is not a bug but intended.

and after 3 seconds the "1 file to download" was gone it still showed me 100% but when I pressed the play button it did nothing

Have you tried to run Gw2.exe (or the Gw2-64.exe) in Compatibility Mode?--> Properties --> Compatibility tab --> Run this program in compatibility mode for: Windows 7

Also, have you tried installing the game on a different partition than the C:\ drive?

Link to comment
Share on other sites

@Ashantara.8731 said:

@"balmyard.2064" said:I'm running windows 10 I've triple checked that all of my drivers are up to date.

Well, there's the source of your problem: Windows 10. It's a bumpy OS with unwanted updates that are being forced upon the user. With each update come new issues with a variety of games.

after it was done I had 1 file left but it say that I downloaded 100% (the 100% showed even when I had 900 or so files to download)

The files are ALL being stored in the Gw2.exe (or the Gw2-64.exe). There are no separate single files. That is not a bug but intended.

and after 3 seconds the "1 file to download" was gone it still showed me 100% but when I pressed the play button it did nothing

Have you tried to run Gw2.exe (or the Gw2-64.exe) in Compatibility Mode?--> Properties --> Compatibility tab --> Run this program in compatibility mode for: Windows 7

Also, have you tried installing the game on a different partition than the C:\ drive?

I did try in difrent partition didn't tried the compatibility mode but I did try using vpn and it worked.ty non the less :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...