Jump to content
  • Sign Up

MacOS 64bit client stops downloading

Recommended Posts

Hello everybody,

I've tried to find some information about this issue but was unable to find a solution, thus im creating this discussion. I used to play GW2 on my old PC long time ago, and recently decided to try it on my Mac.

I downloaded the 64 bit client and it started downloading just fine, but just about 5% of becoming playable it stoped. I tried disabling the firewall, repairing the client and changing the language but to no avail. Ended up quitting until today I decided to try again, and the client stops at exactly the same point. The GW2.dat as 6.14 gigabytes and does't go past that.

Any idea how to fix this?

My computer is a maxed out mid 2015 15 inch MacBook Pro with an AMD R9.

Thank you all.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...