Jump to content
  • Sign Up

Game starts but I see nothing (not due to new patch)


Recommended Posts

Hi,Sometimes when I start the game nothing appears on my desktop, I keep seeing it as if I didn't start the game but I can hear the ingame music and I can't click on anything anymore... The only way to close it at this point is to restart the pc or switch user and this can only be done by pressing Ctrl+Alt+Delete and then from the blue screen I can switch user. Even if I try to close it from task manager I still can't because I can't click on anything...

I hoped this would be fixed by the new patch but the problem is still here.

Does anyone know how to solve this issue?

Sorry if this was addressed in the past but I couldn't find anything helpful with the search function on the forum.

Link to post
Share on other sites

@Hilirith.1073 said:Hi,Sometimes when I start the game nothing appears on my desktop, I keep seeing it as if I didn't start the game but I can hear the ingame music and I can't click on anything anymore... The only way to close it at this point is to restart the pc or switch user and this can only be done by pressing Ctrl+Alt+Delete and then from the blue screen I can switch user. Even if I try to close it from task manager I still can't because I can't click on anything...

I hoped this would be fixed by the new patch but the problem is still here.

Does anyone know how to solve this issue?

Sorry if this was addressed in the past but I couldn't find anything helpful with the search function on the forum.

If you have a login setup from the GW2 icon using a command line for -nopatchui and two step authentication on the account you will need to log into the client using the login ui normally and enter a new authentication number thats normally what stops the game from opening and stays on a black screen

Link to post
Share on other sites

@skillze.7689 said:

If you have a login setup from the GW2 icon using a command line for -nopatchui and two step authentication on the account you will need to log into the client using the login ui normally and enter a new authentication number thats normally what stops the game from opening and stays on a black screen

Thanks for the reply,

I didn't change the login setup and I don't have the two step authentication for my account either. The screen doesn't go black, I see my desktop background but I can't click on anything, also, the mouse cursor changes to the one I have in the game menu.

Link to post
Share on other sites

@TexZero.7910 said:If you're running Win 10 build 1803 then you'll want to1) Go to Settings2) Turn off Focus Assist3) Right click GW2 icon go to Properties4) Click the Compatibility Tab5) Check Disable Full Screen Optimization.

Thank you very much :)

I don't have Focus Assist but disabling the Full Screen Optimization seems to have done the job.

I've logged in and out a few times to see what happens and everything was ok.

Thanks again.

Link to post
Share on other sites
  • 2 years later...

I'm having the same problem this guy is having. I open the game and nothing changes but the mouse icon, and I have to restart my computer to be able to do anything else. I don't have Focus Assist on, and I disabled the Full Screen Optimization, and now when I open the game, it's a black screen with the mouse icon and I still have to restart my computer.

Link to post
Share on other sites
  • 1 year later...

I noticed that this also happend to me a few times too recently (after login and pressing "Play" button a black screen with a white cursor and a background music occurs).

 

A note for you guys - you do not need to restart a whole pc, just open "Task Manager" (ctrl + alt + del) and then end a process of the game (right click on gw2.exe and "End task").

If the game overlays your task manager after opening it you need to set its "Options -> Always on top" to true (checked) - "Options" is in the top bar between "File" and "View" tabs. You can do this even after the game overlays it at first - do ctrl+alt+del, select task manager, then press "o" to open options and press enter to enable "Always on top" (it is first option).

Link to post
Share on other sites
19 hours ago, zemiacsik.4590 said:

...A note for you guys - you do not need to restart a whole pc, just open "Task Manager" (ctrl + alt + del) and then end a process of the game (right click on gw2.exe and "End task")....

Only problem with this is clicking doesn't work. The way to get around this is type "G" to highlight the GW2 process and then "Del" to delete it. At that point GW2 will close and everything will be responsive again.

  • Like 1
Link to post
Share on other sites
1 hour ago, Blude.6812 said:

It is an ANET issue because of the patch. And, as usual, Anet is demonstrating again that they have no respect for their customers! Other than  a post acknowledging the problem they are missing in action and afk.

Well over 24 hours ago now they said they had a fix, but they still haven't released it, so that makes it even worse.

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...