Jump to content
  • Sign Up

Gem store problems? (Belgian players not able to buy/redeem gems?)


Recommended Posts

Since yesterday night I'm not able to buy any gems through the gem store, giving me an error every time. Also the "redeem" button for gem codes stays grayed out, always.I've submitted a ticket, and cleared my cache/ repaired the client.But I was wondering if other people are having this issue? I've asked in-game but haven't really gotten any answers.I'm on the EU server btw.

EDIT: After asking around here and in-game, it seems this is a Belgian issue, as every single person who has the same problem as me is Belgian.Anet please look into this???

EDIT2: I have tried using a VPN and that makes it so the interface works, but when I enter a valid code, it still gives me an error.In other words, using a VPN will get the gem buying interface to work, but actually buying them/using a code still gives errors.

EDIT3: When using a VPN, "Belgium" is no longer available as a country in the list for billing locations. (thank you Sidunox.2401 for the info)

EDIT4: Belgium has been removed off the list of countries from the website store as well. (thank you hoewhoew.4619 for checking)

REDDIT POST (regards to Sidunox.2401 for setting it up)

EDIT5: After some comments, and checking for myself, it seems the issue is now fixed! I was able to redeem my gem code!

EDIT6: We have an official statement from Anet. Gems have been disabled because of the new law, they are working on a solution.

EDIT 7 (FINAL): Another official statement has let us know that certain purchases have been made unavailable in Belgium like the keys, the mount licenses, the dye kits, and any packs that include any of those. Everything else, and gems in general, can still be purchased. This seems to be the end of it.

Link to post
Share on other sites
  • Replies 107
  • Created
  • Last Reply

Top Posters In This Topic

@"Sidunox.2401" said:Yep, I've been having trouble as well since yesterday. I don't know about the redeem button, but I do get a red error when I click on the blue "Buy Gems" button.Is this the error? Because this is the one I'm getting. https://imgur.com/d9KjFtpI hope it gets fixed soon, cause I want that raptor. :(

YES! That's the same issue I'm having! I hope it gets fixed soon as well.Can I ask what country you're from? I wonder if it's a local issue.

Link to post
Share on other sites

@Linken.6345 said:Well they might remove your whole access instead of trying to figure out how to remove 1 itemEditAnd aint there two items black lion chests and mount adoption licenses?

Removing all gem revenue from an entire country seems a bit much from a business standpoint. We're a small country so I can't imagine a MASSIVE loss of revenue on their part, but still big enough that a company would like to hold on to it, I think.Disabling the ability to buy black lion keys, and random adoption licenses seems like a better idea.Then again I'm not the CEO of anet, so hey.

Link to post
Share on other sites

@Akerure.7932 said:So uhm, im having the same problem and im also from belgium... O.o

yeah ok this is clearly starting to paint a picture here.I let Anet know that all of Belgians seem to having this issue, through my support ticket.If you can tho, please send a ticket as well, and let them know about this. It's the only way we'll get a solution, and an answer.

Link to post
Share on other sites

@Inculpatus cedo.9234 said:I'd think if everyone from a country was having an issue, there would be more feedback. It may just be coincidence.

The best strategy is to contact the Billing CS Team via the 'Support' link above/below.

Good luck.

You're right, it absolutely could be. I just feel that more than three people having the exact same problem seems to be more than a coincidence.Although I'm hoping it is.

Link to post
Share on other sites

@XioGShep.4021 said:I'm having this issue now as well. I am from the US though.

Purchased 1600 gems. Went to purchase another 800, and it just keeps throwing errors at me. So I decided to buy a gem card, went to redeem the gem card, and even that is giving me an error..

When did you buy them? If it was yesterday or the day before that, it's not the exact same problem, as I (and others) haven't been able to buy gems since then.In any case, I'd send a ticket to support if I were you. Hope it clears up soon!

Link to post
Share on other sites

I have tried using a VPN to make it look like my internet connection comes from another country (I tried Romania), and it worked. I conclude from this that the problem really does only occur in Belgium. :/

Edit: Never mind, it just screws up the interface a bit. It only shows the "4000 gems for 50€", but when I click on it, nothing happens or appears. So even then I'm not able to buy gems.

Link to post
Share on other sites

@"Sidunox.2401" said:I have tried using a VPN to make it look like my internet connection comes from another country (I tried Romania), and it worked. I conclude from this that the problem really does only occur in Belgium. :/

Edit: Never mind, it just screws up the interface a bit. It only shows the "4000 gems for 50€", but when I click on it, nothing happens or appears. So even then I'm not able to buy gems.

That is so bizarre.......do you think it's tied to your IP address maybe? Also, if you use a VPN, can you redeem a code?(you can type in random numbers and letter in the box, and check if the 'redeem' button stays gray. )

Link to post
Share on other sites

Alright, I may have forgotten about the option of changing the billing country. When I changed the billing country to the VPN country, it seems everything is fine and all payment options appear. I'm not sure if it's legit to buy gems that way, though. I'm not risking it. And yes, when I entered random numbers, the redeem button became active! This just makes me more and more curious as to why it doesn't work in Belgium. :c

Link to post
Share on other sites

@Sidunox.2401 said:Alright, I may have forgotten about the option of changing the billing country. When I changed the billing country to the VPN country, it seems everything is fine and all payment options appear. I'm not sure if it's legit to buy gems that way, though. I'm not risking it. And yes, when I entered random numbers, the redeem button became active! This just makes me more and more curious as to why it doesn't work in Belgium. :c

That is SO ODD. I'll give that a shot myself until anet gives a solution themselves.Thanks a lot for going through that effort and letting us know, it's really appreciated.

Link to post
Share on other sites

@Linken.6345 said:Well they might remove your whole access instead of trying to figure out how to remove 1 itemEditAnd aint there two items black lion chests and mount adoption licenses?

Guild Wars 2 has more than just the Black Lion chests. Remember, some of the mount skin items fall under this jurisdiction as well.

Edit: And there are also the dye kits...

There is more than just one item they need to change

Link to post
Share on other sites

@Zeivu.3615 said:

@Linken.6345 said:Well they might remove your whole access instead of trying to figure out how to remove 1 itemEditAnd aint there two items black lion chests and mount adoption licenses?

Guild Wars 2 has more than just the Black Lion chests. Remember, some of the mount skin items fall under this jurisdiction as well. And there are also the dye kits.

yeah, I know. We mentioned the mount licenses in the post.

Link to post
Share on other sites

I have another update on my research.. After realizing the "billing country" problem, I have noticed something peculiar. My billing country is automatically set as "BEL", not "Belgium". Choosing another country always shows the full country name. A closer look at the list of billing countries has brought me to the conclusion that Belgium is not in that list anymore.. Come on Anet, I need some clarification on this.. :/

Image/Screencap of the list: https://i.imgur.com/LQ1razg.jpg

Link to post
Share on other sites

@"Sidunox.2401" said:I have another update on my research.. After realizing the "billing country" problem, I have noticed something peculiar. My billing country is automatically set as "BEL", not "Belgium". Choosing another country always shows the full country name. A closer look at the list of billing countries has brought me to the conclusion that Belgium is not in that list anymore.. Come on Anet, I need some clarification on this.. :/

Image/Screencap of the list: https://i.imgur.com/LQ1razg.jpg

Thanks so much for this information! It's very useful! This is so strange!I just REALLY wish Anet devs would give some official info about this, because we're just messing around in the dark here.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...