Jump to content
  • Sign Up

Kenning Testing Ground Waypoint


Recommended Posts

The Kenning Testing Ground Waypoint (Dredgehaunt Cliffs) is bugged and permanently contested. For this reason, I cannot progress any further in my quest to craft a precursor for Chuka and Champawat. Upon a little search, it seems this has been an issue for the past 2 years. Any ETA on the fix? Or a work-around so I can progress with the weapon?

Link to comment
Share on other sites

There's two events there; I don't think either one have anything to do with the Waypoint. If the Waypoint is contested, it usually indicates an event is taking place there.https://wiki.guildwars2.com/wiki/Stop_the_jotun_from_stealing_back_their_ancient_weapons

Have you tried a -repair to the client? https://wiki.guildwars2.com/wiki/Command_line_arguments#-repairOr a different IP map?

Good luck.

Link to comment
Share on other sites

Yep, tried waiting longer as well. No use, the event chain is completely broken.I've tried to get into a different IP instance, but ended up in the same map despite trying guesting etc. The only way out it seems is trying it once server resets. Unless a dev can help earlier.

Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...