Jump to content
  • Sign Up

Firebrand Mantras Stuck On Third Cast When Recharging


Recommended Posts

(Tried posting this on another version of the GW2 forums but wasn't working. Hopefully more luck here.)

So I looked for a moment and didn't see anyone else mentioning this, but I ran into a bit of a bug with the Firebrand Mantras. This may be a problem with Mesmers as well, but I haven't checked.

Essentially, the mantras occasionally get stuck on their final version even when gaining more stacks, and stay on that final version when fully recharged to three. What this means is that when you use these mantras in that state, they reset completely, regardless of having three charges. I've had this happen with my healing mantra, my fire condition mantra, and my condition removal mantra.

I can't tell if it's a bug that happens when a firebrand is on their final version of a mantra and goes into a down state while the mantra recharges, if it's that case but with mounting instead, or if it just happens to bug randomly, but it has been pretty annoying to deal with in the middle of a fight.

Picture will be linked to show what I mean.


Link to comment
Share on other sites

  • 1 month later...


This topic is now archived and is closed to further replies.

  • Create New...