Jump to content
  • Sign Up

Recommended Posts

There are numerous bugs with the mounts that I have encountered with mounts and that my friends have encountered.

BUGS

Jackal Portal

  • When you use your jackal mount and go through a portal you will lose the ability to maneuver him on the other side of the portal. You may tell him to go left and he will go right or the camera will move and your jackal will not. The only way to fix this is to demount and remount which can be frustrating when you are trying to evade a lot of enemies on the other side of a portal.

Griffin Movement BugWhen you use your griffin and mount and begin to fly you may find yourself unable to move your griffin. The mount may be inclined to move to the right or left and when you try to move him towards the direction you want it may go the opposite direction or just keep him straight. Also the griffin will have a camera view problem that will enable you to move the camera with your arrow keys but your griffin will not change direction.

Griffin Pocket Raptor ProblemWhen you fly above verdant brink at incredible heights nowhere near the ground, you can get killed by pocket raptors which are really far below you. They should no means be able to hit you, but sometimes they do hit you and kill you instantly causing you to fall far to the ground.

MountingWhen you try to mount sometimes it does a number of bugs based on the mounts you try to hop onto.

  • RAPTOR
    • The raptor when the bug occurs will be invisible and your camera field will freeze. You can see your character icon move on the mini-map, but you do not move on your screen. After a few minutes the screen will quickly update to your position and your camera view will be messed up and you can't move your camera view or you can move your camera view with your keys, but you can't move your mount or even character. Only way to correct this is to re-log.Springer
    • Sometimes High Vault can not be used until you jump once after mounting. This happened when the latest bug fix came out.
  • SKIMMER
    • Exactly like the raptor, the skimmer will be invisible on your screen as you mount and your character will remain invisible. You can move on map, but not on your screen. Keep in mind you can still take damage when this bug occurs.
  • JACKAL
    • For this bug when you mount your jackal will be in T-pose position and will be at base graphics. you can have the map loaded in and be waiting in an area for a long while, but this bug will still occur. Thankfully you can still move around, but it can only be in straight lines until this bug corrects itself a few minutes or seconds later.
  • GRIFFIN
    • Mounting up takes longer with the bug and can have any number of issues shown for the mounts above.

Mount De-mounting BugWhen you demount using the X button when you are on a mount. Sometimes your character will show that you are still mounted on your abilities bar and you can't do anything unless you hit waypoint or 'sometimes' use your mouse cursor to hit the demount button.

Flying Raptor BugThis is a recent bug that happened to one of my friends and is honestly quite hilarious. This player does not have a griffon and when they get on their raptor they can sometimes fly their raptor like a griffin. The raptor will be stuck in a static model position and the player can literally fly his raptor around the map. It looks hilarious and had the guild laughing for a good half-hour. Despite this the bug needs to be fixed.

MOB attachment BugWhen you are flying on a griffin sometimes a mob from the floor levels will get attached to your mount and try to attack it. I had the fun opportunity of having a Veteran Vinetooth in Auric Basin follow my mount and keep clipping to my position even though I was flying high above the map. Eventually the MOB will leave you alone as you leave the position it patrols, but it can be frustrating to have a mob hit you in the air as you are flying and you can't avoid it.

Honestly the most annoying bug on here is when you have the mount and you lose the ability to control it. I have done many parkouring events with my mounts only to lose control of my mount and have to wait for my mount to hit solid ground so I can demount and remount again so I can try to redo what I had done before. This is a frequent bug and is painful to deal with.

EDIT:This bug is universal. All classes, races, and servers deal with this issue from what I have seen myself and heard from others. Every map build from HOT, Tyria, to POF experiences these issues.

Link to post
Share on other sites

@"Gaile Gray.6029" said:Hey Guys,

I just did a search in the Known Issue Tracker for mount-related bugs, and I got several "hits."

Can you verify that all of the bugs reported above are not in the KIT? I would be happy to route this thread to the QA Team, but I don't want to send them bugs about which they're already aware.

Thanks.

Is the 'Known Issue Tracker' just the list on that one page? Because the only active mount bug I see on the page is that equipping skimmers cause crashes for some people.

The recently solved list has "Elementalist: Activities which replace the user's skill bar (transformations, mounts, etc.) can cause elementalist attunements to become stuck or displayed incorrectly." which might possibly related to PolarTitan's 'Mount De-mounting Bug' and it's also possible that PolarTitan's description of a player being able to fly their raptor like a griffon could be related to the recently-solved bug, "Players can sometimes glide while mounted" though it sounds like quite a bit more than gliding occurred.

Apart from those two possible related items, I am not seeing anything on the KIT list that sounds like the bugs reported here.

Link to post
Share on other sites

@"Gaile Gray.6029" said:Hey Guys,

I just did a search in the Known Issue Tracker for mount-related bugs, and I got several "hits."

Can you verify that all of the bugs reported above are not in the KIT? I would be happy to route this thread to the QA Team, but I don't want to send them bugs about which they're already aware.

Thanks.

@PolarTitan.8519 said:There are numerous bugs with the mounts that I have encountered with mounts and that my friends have encountered.

although not that game-breaking, i'd like to let you guys know (and follow up on @"CETheLucid.3964" 's thread) of a bug regarding bow strings (long or short bow on any profession/race/gender that can use such weapons) disappearing after using the mount engage/attack (all mounts) skill:

https://en-forum.guildwars2.com/discussion/comment/744500

it's not on the Issue Tracker either after doing a good search

Link to post
Share on other sites

@"Cragga the Eighty Third.6015" said:Another small bug, which I have never seen anyone else mention:If you hit M to look at the map while unmounted, and hit the mount button while the map is still up, when you exit map mode, the camera will be looking down on you from far above.

I've seen that one happen. It's not often reported, I think, because it's a slightly odd sequence of things to do, but I do see it once in a while.

Link to post
Share on other sites

@"Pooty Tang.8104" said:The mount related bugs in this thread: https://en-forum.guildwars2.com/discussion/26175/pet-does-not-spawn-on-ranger-dismount#latest are also not listed in the known issue tracker, thanks.

I would like to add to this that this is not exclusive to ranger pets, but also includes necro minions. Necros have the additional hardship that when their minions do not spawn when dismounting (although they were present when mounting up), they have to recast each and every one of their minions instead of just switching to the "other" pet like a ranger. When mounting up and then dismounting shortly after, that also means you will even have a cooldown on your "lost" minions. Not nice!

Link to post
Share on other sites

@"Gaile Gray.6029" said:Hey Guys,

I just did a search in the Known Issue Tracker for mount-related bugs, and I got several "hits."

Can you verify that all of the bugs reported above are not in the KIT? I would be happy to route this thread to the QA Team, but I don't want to send them bugs about which they're already aware.

Thanks.

Hey thanks for seeing the post. From what I see, no I don't see the issues on there from what I look at. Only reason why I posted this was because many of us in the community have these issues and many of my listed bugs are quite common. Thanks again and please pass this on. I would love to see the mounts fixed cause it's honestly a pain in the game to deal with this. <3

Link to post
Share on other sites

@Astyrah.4015 said:

@"Gaile Gray.6029" said:Hey Guys,

I just did a search in the
for mount-related bugs, and I got several "hits."

Can you verify that all of the bugs reported above are
not
in the KIT? I would be happy to route this thread to the QA Team, but I don't want to send them bugs about which they're already aware.

Thanks.

@PolarTitan.8519 said:There are numerous bugs with the mounts that I have encountered with mounts and that my friends have encountered.

although not that game-breaking, i'd like to let you guys know (and follow up on @"CETheLucid.3964" 's thread) of a bug regarding bow strings (long or short bow on any profession/race/gender that can use such weapons) disappearing after using the mount engage/attack (all mounts) skill:

it's not on the Issue Tracker either after doing a good search

Thanks for this!

Link to post
Share on other sites

Hey Guys,For over a week, I'm also having problem with my mount. It's not related with any proffesion, just with mounting/dismounting.When I'm mounting my Raptor, suddenly camera is changing and I'm seeing not back of my character, but his front (face).This would not be such a big deal, but when camera is changing 180 degrees, movment of the character is not changing. So now when I press "W" forward, camera is showing me my character, and not whats in front of him. I'm basically moving forward and not seeing where I'm going. Changing camera position is not helping with anything, because my character is always comming in my direction (players) and not in the opposite direction.Dismounting corrects this camera issue and I'm again able to see back of my character.

Can someone tell me if this issue was already somewhere mentioned?

Link to post
Share on other sites

@"Rashoq.6397" said:Hey Guys,For over a week, I'm also having problem with my mount. It's not related with any proffesion, just with mounting/dismounting.When I'm mounting my Raptor, suddenly camera is changing and I'm seeing not back of my character, but his front (face).This would not be such a big deal, but when camera is changing 180 degrees, movment of the character is not changing. So now when I press "W" forward, camera is showing me my character, and not whats in front of him. I'm basically moving forward and not seeing where I'm going. Changing camera position is not helping with anything, because my character is always comming in my direction (players) and not in the opposite direction.Dismounting corrects this camera issue and I'm again able to see back of my character.

Can someone tell me if this issue was already somewhere mentioned?

I have seen this issue before as well. There seems to be a camera issue when you mount up sometimes and you lose the ability to maneuver your mount since the camera view is so skewed. For me it mostly occurs when I am on my jackal or my griffin, though I am not surprised that it is happening for the other mounts as well.

Link to post
Share on other sites

Mounting doesn't kill my utility skill minions, but mounting does kill my death nova minions (regardless of their 30 second life span). This is unfortunate since open world PvE is where minion mastery shines. I no longer get the ramping potency of stacking multiple jagged minions in open world when I mount between every fight.

Link to post
Share on other sites
  • ArenaNet Staff

Thanks for your continued patience and for the details that you are providing. It's super helpful to include details, and maybe you could edit your post to add the following:

  1. What server are you on?
  2. What profession are you playing?
  3. Is this universal to various characters, or just to a specific one?

Generally I ask for your location, but I don't think that would be relevant here. Still, a dev may pop into this thread to ask for other info.

Link to post
Share on other sites

@Astyrah.4015 said:

@"Gaile Gray.6029" said:Hey Guys,

I just did a search in the
for mount-related bugs, and I got several "hits."

Can you verify that all of the bugs reported above are
not
in the KIT? I would be happy to route this thread to the QA Team, but I don't want to send them bugs about which they're already aware.

Thanks.

@PolarTitan.8519 said:There are numerous bugs with the mounts that I have encountered with mounts and that my friends have encountered.

although not that game-breaking, i'd like to let you guys know (and follow up on @"CETheLucid.3964" 's thread) of a bug regarding bow strings (long or short bow on any profession/race/gender that can use such weapons) disappearing after using the mount engage/attack (all mounts) skill:

it's not on the Issue Tracker either after doing a good search

Yea, hopefully this will get more attention aswell.

Link to post
Share on other sites

@Gaile Gray.6029 said:Thanks for your continued patience and for the details that you are providing. It's super helpful to include details, and maybe you could edit your post to add the following:

  1. What server are you on?
  2. What profession are you playing?
  3. Is this universal to various characters, or just to a specific one?

Generally I ask for your location, but I don't think that would be relevant here. Still, a dev may pop into this thread to ask for other info.

Since noone answered you yet @Gaile Gray.6029 on this Question, let me be the first one. (The Bug is really anoying)

  1. Underworld but tbh i dont think that matters much. I have another Account on Dzagonur and it happens there as well (seems not serverbounded)2./3. The "Rule" from 1. goes along here as well. Doesnt matter. Soulbeast Mirage, Spellbreaker, Daredevil …. happened to all. Cant say if the Bug is Profession related but i guess not and it defnitly happens to various characters.

Let me give you some further Information. "When this Bug happens most?"Through my own experiences i would say it happens the most after you teleported to a waypoint and want to mount up afterwards. (Map loaded, Charakter loaded already etc) But when you mount up …"The raptor when the bug occurs will be invisible and your camera field will freeze. You can see your character icon move on the mini-map, but you do not move on your screen. After a few minutes the screen will quickly update to your Position" - PolarTitan.8519The Diffrence between his/her experience and mine is that my camera never got messed up etc.The Bug also occurs often when Meta Events are going on. Tarir, Tengled Depths, Dragonstand, Istan (aka many ppl around)But it also feels like the Bug occurs "randomly" when nothing above were done.

https://i81.servimg.com/u/f81/19/85/58/82/gw22910.jpg

Just show you how it looks, here a Little Screenshot. You can see that i moved on the Minimap, but my Charakter (Soulbeast in this Case) is stuck on her invisible mount. I can only speak for the Raptor Bug, i dont use the other Mounts that often.

Further further Information :astonished:Can only speak for myself now. When you are in the Buganimation, you already moved while the Bug is active (you can see that on the minimap) and then you decide to leave your mount, you get "teleported" back where you mount up. You can only watch this on the minimap since your Charakter is somewhat frozen on its invisible mount(I could still turn my camera around to make that fancy screenshot ;D). If you are lucky you can move around normaly after you left your mount in the Buganimation BUT it can happen that you get stuck in the Ground. (I even fell through the Bridge under Tarir when I wanted to loot all the chests)

I hope this Bug get solved as fast as possible. Its really annoying when you can (finally ) use Mounts but everytime you mount up your facing this Bug.

Hope I could help you o/

Link to post
Share on other sites

Few people talked about it in this thread as wellhttps://en-forum.guildwars2.com/discussion/62915/default-skin-mounts-still-do-not-load-properly

In addition, to what I already said above - yes the Bug happened on the default-skin mounts (Raptor in my case).I dont have Mountskins, so I dont know if the Bug occurs there as well.

Btw. "I didnt see this one on the known issue tracker either." - same for me.There are some "hits" about Mountbugs (Springer to high, crash on skimmer etc.) but nothing that adresses this Bug

Link to post
Share on other sites

I'm on Piken Square, and I mostly see those bugs on my thief, probably because she's simply the character I use mounts on the most.

@PolarTitan.8519 said:MountingWhen you try to mount sometimes it does a number of bugs based on the mounts you try to hop onto.

  • RAPTOR
    • The raptor when the bug occurs will be invisible and your camera field will freeze. You can see your character icon move on the mini-map, but you do not move on your screen. After a few minutes seconds the screen will quickly update to your position

This happens mostly when waypointing to a map location where there are lots of players around. So it happened a lot in Divinity's Reach during the recent Wintersday celebration. As a first, I also had this happen several times in Wintersday DR in a way that I'd never seen before:I'm doing the orphan gift daily and I'm approaching an orphan while I'm already on my raptor, i.e. the skin and model are already loaded. I dismount, quickly go through the gift giving dialog sequence and try to remount, triggering the bug.

Mount De-mounting BugWhen you demount using the X button when you are on a mount. Sometimes your character will show that you are still mounted on your abilities bar and you can't do anything unless you hit waypoint or 'sometimes' use your mouse cursor to hit the demount button.

I only get this bug when when doing the combat dismount on the griffon. Hitting the mount/dismount button again will fix it for me.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...