Jump to content
  • Sign Up

Why is Roller Beetle on Mouse steer borked?

Recommended Posts

Yes I call it borked, and I will explain why:

I know how to break, turbo, drift... but whenever I test in a large flat area, with mouse steer I cannot turn as sharp as with WASD.This is the only mount showing that behavior, and it is frustrating me, because it gives me great troubles.

"So use WASD" you'd think... but that's the problem, I can't.Due to severe limitations in my left hand, I cannot use that without experiencing pain.

So my question is, how do I steer as sharp with mouse steer as with wasd?And if it can't be done, why not? Why can I not steer as well as everyone else?

The power of Guild Wars 2, that I found so far, is the heavy amount of modification, letting someone like me experience the game without a disadvantage.That puts this game on top of many others, yet now with the Beetle Event, it feels that plus has gone out the window.I aced all tracks except the snowden drift one, because that is a tight one, one corner too wide, and your time is busted.The last corner cannot be steered sharp enough with mouse steer, it simply cannot be done... others that normally steer with wasd tried it as well, they said exactly the same, it cannot be done...

Why not? Why is mousesteering so limited on the beetle?The other 5 mounts are fine, not a problem

Link to post
Share on other sites

I tried that, including dulfy's suggestion to hit the tree, I can drift a bit with using the key and moving in the direction I need to go, but not as sharp as when you use the a or d key with drifting.The biggest issue, I cannot push those at the same time, regardless of how I remap my keyboard.

Above post was a bit in frustration mode, I will say that much. It's just annoying that I cannot find a combo that works for me.

The limits are my hands, I mentioned left, but it's actually both. I use my extra mouse button to simulate click and hold, to prevent having to push the button constantly.

Arthritis is a pain for sure.

Link to post
Share on other sites
  • 4 weeks later...

I use mouse steer (holding both mouse buttons in) always when on beetle and I got hold on snowden. I found holding, I think, s and d or s and a (dependant on direction needed to take) and then sharply moving the mouse that direction while holding the buttons down worked fine. ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...