Jump to content
  • Sign Up

English US Keyboard added after launching GW2


RichTea.4572

Recommended Posts

I am located in the UK, and use an English UK layout keyboard. After launching the game (just the launcher isn't sufficient, nor apparently is exiting from the character select screen) a second keyboard is added to my Windows 10 keyboard options for English US layout. This remains after exiting the game. This additional layout is not listed within Control Panel (initially; I think it may appear after PC restart). I have found I can only remove this additional layout by explicitly installing the US keyboard, and then removing it again. The layout is re-added again after launching GW2.

While Windows 10 allows some language configuration, there's an unremovable binding for "WIN+SPACE" to switch system languages, which means once GW2 has added en-US, that key combination will swap you between it and your preferred language (en-GB in my case). A "workaround" which uses an AutoHotKey application is described here (https://superuser.com/questions/1000678/disable-winspace-keyboad-layout-switch-in-windows-10?rq=1) but I haven't tried it, as from my understanding it needs to be constantly running to intercept the hotkey to prevent it doing anything.

Issue also described in this forum discussion: https://en-forum.guildwars2.com/discussion/20181/game-adds-english-us-keyboard-layout[Discussion created as suggested on Ticket #7181507]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...