Jump to content
  • Sign Up

[SOLVED] Massive FPS Drops since New Year / Last Patch


Recommended Posts

Hi all,

today I logged in to check some winterdays content and noticed massive FPS drops (6-10 FPS). My system was able to run GW2 smoothly at 30-60 FPS for the whole year 2018 and now suddenly, I can barely play.

My systemCPU: Intel i5 3570KGPU: NVidia GTX 1050 TiRunning 2 monitors at 1920x10808GB RAMSSDWindows 10

When did it last work?Last thing I remember is doing the roller beetle races in Gendarran Fields and Kessex Hills, maybe in late November. No issues back then. I have not logged in since then, so maybe / hopefully it is related to a Wintersday update?

When does this happen?The issue occurs only in non-instanced content (e.g. Open World, Cities). When I enter e.g. the Sun's Refuge or my Guild Hall, everything is fine and at 60fps again.I just went to the Heart of the Mists, where I had the issue, but as I approached the portal to Lions Arch (where no players stood), FPS climbed up to 23fps. However, I always had this issue in Jahai Bluffs, no matter whether I was alone fighting NPC creatures or having another player near me.

What did I try?

  • tweaking the graphic settings doesnt change anything. Even at everything on "Lowest" / Off I don't go above 12 FPS
  • Task Manager says, CPU load is constantly above 80%, sometimes above 95%
  • Task Manager says, GPU load never surpasses 20% (I am standing still in Jahai Bluffs)
  • I unplugged the 2nd monitor and changed the Display Settings to "Use only 1 monitor" in Windows. Although I got a new 2nd monitor for christmas which replaced my old 1280x1024 screen, I doubt that this will be the issue
  • graphics driver update didn't change anything
  • turning off GeForce Experience / "ShadowPlay" didn't change anything
  • MSI afterburner says, GPU temperature is between 40-60°C

Any ideas what may have caused this issue? I am wondering why this issue appeared "overnight"...

/edit, Solution:There seemed to be a problem with GW2 and the version of arcdps I was using. Uninstalling arcdps (removing the .dll) solved the issue.

Link to comment
Share on other sites

  • 4 months later...

Do you have any recommendations for the same issue with the AMD Radeon Pro 580? I know its not the greatest graphics card, but my game runs PERFECTLY outside of a random drop in FPS from the 60s down to 9 and it stays locked at 9 until I waypoint somewhere, and then its fixed again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...