Jump to content
  • Sign Up

Exploration Compass Screwed Up

Recommended Posts

This been going on for 2 days now.I'm just going to assume though it might be due to the first story mission not being done?

On my Mesmer, while in Gendarran Fields, the tracker would lead to only waypoints and nothing else. Not to Points of Interests, not Vistas, not Hearts, not Renown Spotters, not Hero Points, nothing.

When all Waypoints were collected it just sat there.

On this character, who also has not done the first personal story, had a few problems pop up for him as well.Sometimes shows absolutely nothing, sometimes will tell me to head to 5 things at the same time (flickering in and out of things it tries to guide me to which just causes a major meltdown of the compass) and in the attachment is the newest problem of just going into Bloodtide, it's telling me there's a new place to explore in Lorner's Pass... when I just got into Bloodtide and haven't touched the area as of yet.nBtzm9E.jpg

Doesn't help that the guide usually completely disappears when you're doing a heart and shouldn't be visible now.

Image of no text leading to a vista and later would show me to go in the other direction in a flickering motion that I haven't taken a screenshot of: lMG7WKB.jpg

I've never seen this happen before as well, but would really like feedback on why it's doing this.I know it's not computer-based as my higher level characters who has progressed the level story a bit isn't seeing this happen which I think is due to the story?

Also, the daily being an event completer, I usually tend to turn off everything except events in options so I can get the compass to lead me to events quickly. While doing today's dailies... it didn't point to anything. At all. It just vanished.

Link to comment
Share on other sites

@"Inculpatus cedo.9234" said:Have you tried a -repair of the client? Instructions found in the Knowledge Base accessed via the 'Support' link above/below and 'Search - Repair'.

Good luck.

Yes. Didn't seem to change anything. Even made a special shortcut just for repairs for "Just in case". Didn't change anything.Yes I also tried restarting and shutting down the computer as well.

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...