Jump to content
  • Sign Up

(War Eternal) Landfall scanner not working

Recommended Posts

So I got to Landfall during War Eternal, and I'm supposed to locate seismic interests on the map. Apparently the scanner is supposed to show me a beam or projectile or something that leads me to the seismic interests, but the scanner does literally nothing. I've had people tell me that I need to be airborne because the scanner's beam might be going directly into the ground, so I tried using my springer or gliding at a high point in the center of the map, and the scanner still does absolutely nothing. I haven't met anyone else with this problem so I dunno if I'm just doing something incorrect or what. I was able to find the seismic interest in the Underworld without the scanner, but I've had no such luck in Melandru's domain or the burning forest.

Link to comment
Share on other sites

  • 4 weeks later...
  • 7 months later...

@"Aikaterine.3057" said:I'm experiencing the same problem. I am literally sitting right on top of the blue conical symbol and it still won't work. I'm trying to get my SKYSCALE and can't progress. I've tried restarting, repairing, nothing!! Please!, someone help...I'm sooooo frustrated.

Here's a map to check: https://wiki.guildwars2.com/wiki/Landfall#Walkthrough

You can try a -repair of the client, in case of corrupted files. https://wiki.guildwars2.com/wiki/Command_line_arguments

Good luck.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...